Time signaure change is not respected by beat dependent plugins

Hello everyone,

This questions is not directly related to Cubase but I hoped someone could still help with this. I have a track in which I created a small time signature changed, namely I shortened one bar in half:

After that one shortened bar, everything is back to normal again, with the default time signature. However all my time dependent plugins (LfoTool and GateKeeper) are not aware of this change, so for them the start of each bar (after the time signature change) is actually the middle of the bar, and then it screws up their functionality.

I have no idea how to solve this, and if it’s even possible.
The only thing is a workaround, I just create another time signature change of half a bar, just an empty space, temporarily, so the plugins don’t get confused. And after I finish the project and export to audio I can delete this empty space.

Is there a better way?

Thanks a lot in advance

Give this a try:

Adding Time Signature Events in the Tempo Track Editor

  1. Select Project > Tempo Track to open the Tempo Track Editor.
  2. Select Draw on the toolbar, and in the time signature display, click at the time position where you want to insert the time signature event.
  3. Edit the numerator and the denominator to change the value of the time signature event.
    You can also select the time signature event and edit the time signature value on the info-line.
    The time signature event is added at the specified time position. The timeline and the event displays for the Project window and the editors reflect the changes

I think they left out a step. I had to click on the “Process Bars” icon then I got the dialog shown which allowed me to enter position, length and the time signature shown. I don’t have those plugins to test, but see if this works for you. The “Reinterpret Bars” or “Replace Bars” might be a better option than “Insert Bars”.

1 Like

This might help


1 Like

Thank you very much! I’ll have a look