Time Stretch Echo


Yesterday I tried to edit a vocal part by making a single word a little longer by isolating the word with splits. Then switched to the Time Stretch tool with the Elastique algorhythm (for Time stretch). Every edit I make comes out with a little echo as if two people sang at the same time. I have this problem in Cubase Artist 8.0.10 but I used this before in Cubase Artist 6 and cannot remember ever having this problem. This arftifact makes the feature completely useless.

I tried some other time stretchings (also with warp tabs) but no matter what I edit it all comes out with a little echo (sounding like around 20ms or something like that).

Anyone else having these experiences? Is something broken in Cubase or am I doing something wrong.

Are you certain you haven’t got overlapping/duplicated audio events on top of one another??

I freewarp all the time without any echo.

Yep… I’m sure about that. I tried it with a new project and only one audio file and it still doesn’t sound right to me. It’s not a real echo but more a kind of flanging delay set to 10ms or higher. It gives the feeling as if 2 people singing at the same time.

Anyway… I installed 6.5 to compare and it is the same there. So it is all between my ears. I tried the algorhythm Standard - Vocal and that one sounds good to me as long as you do not stretch it too far. Guess I use that one then.

Sure would like to hear about experiences from others…