Timebase toggle not showing up in Edit window

Had this issue since I updated to Cubase 12 when it first became available. I’ve updated since, currently 12.0.60 on my 2018 iMac. Say I’m working in the Bars/Beat mode. I might switch to minutes/seconds just to work with a vocal using 10 ms bumps forward or back., When I toggle back to Bars/Beat sometimes the edit window still shows minutes/seconds. Even toggling back and forth a few times doesn’t help. This was not an issue prior to the Cubase 12 install. Help would be appreciated.

Musical/Linear Timbase controls how MIDI Parts anchor their Start Position. In Linear it is anchored to minutes & seconds. While using Musical Timbase anchors them to Bars & Beats.

These settings are entirely independent from the Rulers displayed in the Project and Editor Windows. Those Rulers can be set to a variety of different scales (not the musical kind) which you can freely select by right+clicking on the Ruler.

My Bad. I meat toggling between the Bars+Beats and Seconds won’t CHANGE what I see when I am editing a midi or audio part. The window you displayed displays ONLY in the Seconds mode.