Timecode bug ? How to get this to 0

Hello, my timecode is getting crazy, no matter what I input in the project setting timecode offset, it never goes back to 0 at bar 1, it makes crazy jump

Hi,

Could you attach the screenshot of your Project Settings, please?