Timecodes continuous across flows?

Is there a way to have the printed timecodes across the top of my score continuous across flows, so the timecode in the score corresponds to the timecode in the audio file output by Dorico? I see a way to set the initial value for a timecode


but I don’t want to guess what timecode each flow starts at, I just want it to happen automagically?

I’m afraid there’s no way to make this happen automagically: you’ll need to set the timecode at the start of each flow manually.

Thank you Daniel.

It seems like CMD-Shift-P Playback Options | Timing | Gap Between Flows reverts to the 5 sec. default every time the project is opened. Should it be persistent with the project settings or even the global Dorico settings?

Where are you trying to change this gap? That might be your problem.

I know what I’m doing. Working with co-composer, passages come in separately and we bring them together in separate flows then weave them together. I used to have to adjust timing of transitions later in our DAW production mix, but it is a blessing to be able to hear the entire work as a continuous work while still in score mockup form

Can’t help if one doesn’t answer the question.
You said the setting didn’t stick; I asked where you set it.

Sorry, mis read the reply as ‘why’ not ‘where’.

The Gap between flows during playback value is definitely saved correctly. Once you’ve changed the value in the dialog, tab to the next control so that the Apply button is illuminated. Click Apply and Close, then when you save your project, the value will be restored when you next open it.

Yep that’s it, the Apply button was grayed out and I presumed that meant I didn’t need to do anything. Thanks!

I am finding that every time I open the project, I have to CMD SHIFT P Playback options, Timing, and change the gap between flows from the default 5.0 to 0 seconds. Despite applying the change last time. Despite Save as Default last time. It seems like the default is baked in. Perhaps it is resetting to the default whenever additional flows are created in the project? This is not a big deal, just another little gotcha to remember.

Could you attach the troublesome project here, so I can see whether I can reproduce this problem?

I just downloaded your file, set the timing between flows to zero in Preferences, and played from the end of Flow 1 to the start of Flow two without a gap except for the one measure rest you had in between.

I saved the file and closed it; re-opened the file; and it tested the same.

I then exited Dorico altogether; then reopened it; and again the file played from the end of Flow 1 to the start of Flow 2 with only the one measure rest of silence separating them.

Hope you can find what causes your version to behave differently.

Yeah me too. Thanks for the test.

When I change the value for gap between flows from 5 seconds to 0 seconds, save, close and reopen the project, the change of value is definitely saved, as it should be. Could the problem be that you are not tabbing away from the Gap between flows during playback field after changing the value? Dorico won’t register the change of value unless you move the focus to another field.

Nope. This is still happening.

We can’t do anything to investigate without the project itself.