Timeline-zoom weirdness on MacOS with external (or multiple?) displays

Hi Folks!

Does anybody experience the same weird behavior?
Makes the timeline-zoom almost unusable. “Use selection start as Zoom Anchor” is disabled! It does not matter whether stationary playhead is enabled or not. Can any other setting influence this or is ist just a bug?

Watch what I do with the pointer and what the zoom does. Also it seems to react to horizontal movements, which I think it did not in the previous versions at all.
Also when one stops and holds the pointer in one place the zoom just continues on…

EDIT: OH Wow! This is wild:
I just found out that this behavior only shows when I have the project window on my external display (an Apple Thunderbolt Display). As soon as I move the project window to the built in screen of my MacBook the scrolling is super-snappy and works perfectly!!!
Also tried on a super cheap VGA-Display that I use for metering (via HDMI) and it shows the same problem. So it seems it is not related to one sort or brand or connection type but shows on all external displays.
But still: This is an issue that only shows since the new V13.

PS: In the mid portion of the video after my horizontal movement zooms out completely, I used G+H to zoom back in, to repeat the demonstration (with the stopped curser and the zoom still going on). Just to make that clear and not cause any confusion,

I can’s see your video (This video cannot be rendered because your browser does not support the codec.), but is this your problem?

Edit > Preferences > [Editing] Zoom > uncheck “Use selection start as Zoom Anchor”

1 Like

No, i have this one ticked off… That’s what I was referring to as “Snap zoom to event” - I am in a German version and didn’t know the right expression for the function. I’ll edit in my original post. In German it’s “Anfang der Auswahl als zentralen Punkt für Zoom nutzen”

Can you please tell us what you want to have happen, and the tell us what actually happens, without mentioning any specific Cubase function or command?

If you want to zoom in the timeline using the mouse, without moving the playback cursopr, hold shift+alt while dragging.

HI Steve!
Thanks for trying to help.
Were you able to watch the Video?
I don’t really get what you want me to describe. The video shows the problem that dragging the mouse in timeline-zoom-function makes the zoom go all over the place and it is practically uncontrollable.
So what should I describe that I would want to happen? For Zoom to work properly?
I don’t care about the playback-curser - But thanks for the reminder that this functionality exists - but the zoom itself can’t be controlled properly since the V13 upgrade

Sorry if that sounds a bit grumpy, but I just don’t get your posts intent…

No, and neither can others. Are you reading the replies?

Totally grumpy, yes.

Maybe slow your mouse down.

I didn’t mean to sound impolite, I’m sorry if I came across that way.
I do read the replies, of course and I am quite active in the forums trying to help others as well. Up to your post only one person mentioned that the video didn’t work. You didn’t in your initial post.
The video works perfectly in my browser (Safari). I’ll try to replace it with some other codec. It was supposed a normal mp4. The 4 MB limit doesn’t help with uploading video content : /.

I might be better off making this a normal Steinberg support ticket I guess, I don’t want to piss off people here.

My mouse speed is totally normal ; )

Ok, you’re on MacOS. This is an important bit of info.

As to your video, video playback is not universally functional in the forum, so I use animated gifs, which are guaranteed to be playable. I tried viewing your vid in several browsers here, all with the same result.

I am not experiencing the behavior you’re talking about .

I’ll edit the title to get Mac users to notice this.

Thanks for the edit. I tried to make an animated GIF but cold not get it below the 4 MB quota…

then use a filesharing service and link to the vid.

Did that just a few moments ago -replaced the original video. I didn’t know it was showing like this and not just showing a download. Great - now I learned something new. Never posted a video here before. Even earned me a new badge - “onebox link” : )
Sorry for the hassle, Steve!

Now I see it!. That is completely messed up.

Among other things, I observe you are moving the mouse in a straight line downwards, and the program is not responding correctly at all!

  • Have you ruled out prefs issues already?

  • Have you verified that the mouse itself is not broken?

Alright! I’m glad we can talk about the issue now! :grimacing:

Mouse is perfect everywhere else (its a good one :wink:
What I could think of in terms of prefs, I checked and put it in a state where I think it can’t influence the behavior in a negative way.
I deselected the Edit > Preferences > [Editing] Zoom > uncheck “Use selection start as Zoom Anchor” -option.
Stationary playhead or the other option doesn’t make a difference.
So my initial question was: Could there be another pref-setting influencing this? Can you think of one?
At first I thought that maybe it might have to do with the project having a video-track. But the same weird behavior shows with a project with just 3 audio tracks.

I do not think there is any user set-able pref that will break it in the way it’s broken in your vid.

Ruling out prefs problems is a testing step that initializes Nuendo using Safe Mode.

You can also do it by the Nuendo User Settings Folder entirely which will do even more, such as initialize VST plugins params etc.

I don’t think so either.
See my edit in the original post. I just found out it must have something to do with external displays and window handling… I guess that’s one to figure out for the Steinberg-Devs with apple.

Why did you remove your post with the details about that? It would be useful for other Mac users with thunderbolt displays.

Wrote it in the original post - so they can see right away.
also edited the title.

1 Like