Timestretch issues

Hello whoever !
I have wavelab 8 & have been using the timestretch function on an awkward drum track. When I timestretch this particular beat, it automatically increases the volume too despite selecting the Preserve pitch option…
is this normal? I only noticed it this time so I don’t know if it has done that every time or just started now. if possible , how can I prevent this unwanted volume increase?
many thanks in advance