Since I always get absolutely intolerable cracks & pops every time I pitch shift/time stretch any audio file I figured I might want to change the algorithm from ‘Realtime’ to any of the other options provided in Preferences > Editing > Audio > Time Stretch Tool Algorithm

Here’s what I get (pay attention to where I want to stretch the edge of the file to and where it actually ends up)

Anyone know what is causing this?

What I’ve tried so far:

  • Steinberg’s ever so praised yet never working solution to every single one of humanity’s problems usually referred to as “Reset Preferences”
  • switching my computer off and back on (cause you never know)

What I’m going to try:

  • Throwing my computer into the Spree river or switching to a DAW that for once behaves like expected


Cubase 10.0.30

MacBook Pro (15-inch, 2018)
macOS Mojave 10.14.5 (18F203)
2,9 GHz Intel Core i9
32 GB 2400 MHz DDR4
Radeon Pro Vega 20 4080 MB
1TB SSD internal
4TB SSD external via USB-C
5TB HDD external via USB-C
UAD Apollo Twin MKII via Thunderbolt 2 to USB-C Adapter
Apple Magic Mouse 2 via Bluetooth