timing adjustments don't work

I use HALion Sonic SE as playback device and I’d like to change the duration of the staccato notes.

I go to ‘playback options’ -> ‘timing’ -> ‘note durations’ -> ‘Staccato notes’.

If I change the value here, nothing happens. Even if I go to 0% or 100%.

What am I doing wrong here please?

Could it be that the playback device you’re using is using a staccato sample, in which case changes to the length of the MIDI note won’t take effect? You can check the length of the note that Dorico is actually outputting by looking at the piano roll in Play mode.

This is the playback device I’m using.
The changes don’t work for any of these instruments.

Yes, all of those instruments have sampled staccatos, so Dorico will use them unless you remove the staccato switches from the expression maps.

Ahhh…so if I remove the staccato switches, I can work with ‘playback options’ -> ‘timing’ -> ‘note durations’ -> ‘Staccato notes’

I didn’t know that. It makes absolutely sense.
I thought that HALion SE is the standard playback device and that’s why every change in the playback options automatically changes the behaviour of the HALion SE instruments. Now I understand.
Thanx