Timing issue

using cubasis 1.8.3
On ipad osx 7
tested on ipad mini and ipad

I have noticed that recording either midi or audio using metronome
all events recorded in to a clip are offset -1 beat…

I have tryed to record a 1, 2, 3, 4 beat using a bass-drum as a test.
metronome is counting 1, 2,3,4 etc…
I play the bassdrum like so 1,2,3,4

when examine the clip you would expect to see all hits on the beat or maybe a lttle late, however the beats are not on the beat or showing latency they are offset to an earlier time which does not make sense. Example below is for a 2 measure recording in to the 2nd measure

Metronome > 1= 2= 3= 4= 1= 2= 3= 4=
Recorded >…1= 2= 3= 4=

I can understand if latency was the issue in which case we would see
Metronome > 1= 2= 3= 4= 1= 2= 3= 4=
Recorded >…1= 2= 3= 4=

To recreate the problem do as follows…

  1. open a new project
  2. enable metronome
  3. create a midi track and arm
  4. press record
  5. tap a key on each beat for upto 2 measures
  6. stop

examine the midi clip.


at the moment I can not reproduce the issue… could you also update your iOS to the latest version of 8.1


Did the update
Not sure if it fixed it (seem to work okay)
But may have something to do with latency settings too…
Im stil testing
Have noticed that sometimes tracks within cubasis go out of sync with others currently playing
seems a bit clitchy…
or maybe using start stop in the middle of playback can cause the same.
again… I will get back with more specifics if i can narrow it down.

Hi Quinnx,

As Ricky replied no offsets should appear when performing regular MIDI / audio recordings with Cubasis.
Please provides us with detailed setup infos and exact repro steps in order to check the issue.

Furthermore please have a look at this topic (in case the problem is performance related):

Hope that helps,


here is one of my issues…
when recording a 2 bar loop (midi) cubasis missed the 1st note on the 1st beat.
further more, when we reach the end of the loop, and get ready to play a note on the 1st beat as it returns
to the beginning of the loop…
cubasis catches the note right at the very end of the loop instead of placing it at the beginning of loop,

for the purpose of demonstration
using internal instruments we record a 2bar loop which is midi
set the loop markers start at bar 2 and end marker at bar4 (2 bar loop)
set record mode to IN

Make sure the playhead is at 0.00.00
enable metronome
arm track
press play then record (because you currently cannot hit record because it automatically jumps to the start marker)

as you listen to the metronome, as soon as the play head reaches the record in point make sure you play the 1st note on the 1st beat and continue to play to end of loop and allow it to loop and listen to the results.
either the 1st note will not be captured on that first pass or as you allow it to do another pass and attempt to play and capture the 1st note again, it will be captured at the end of the loop instead of the beginning.

After experimenting with various latency options… the best conclusion is that we need a Metronome offset option
so we can change how soon or how late the metronome plays to get correct time… right now the results are showing that the metronome plays too soon.

Hi Quinnx,

I gave the issue another re-check and things work as expected here.

Please note that it is not required to hit play and record to start the recording (and it is impossible to locate the playhead at 0.00.00)!

Please give this procedure a try:

  • Open “Rec Mode” menu and make sure “Count” is highlighted (leave all other options out)
  • Create a MIDI track and load an instrument from Micrologue or MicroSonic
  • Set the locator at your wish
  • Activate click and cycle and hit the record button to start your recording

While - depending on timing and other factors - it can happen that notes will be missing at the first bar or will be placed at the ending this should not be the case when proper triggering is granted.



Thanks I do more testing and let you know results

On the issue of note drop for beginning of recording and end of loop…

Lets looking at this logically…
when one clicks record, regardless of how early the 1st note is pressed it should always always be captured.
As a suggestion…
Lets say to resolve the issue, cubasis does a quantize check on the last note played just before the beginning of the recording and lets say we set a rule that says… if the the last note played is within the last 1/32 or 1/64 of the timing it is captured and placed at the beginning of the loop and the same goes for the last note played at the end before it loops.
and maybe we can set up an option in settings to allow the user to define this timing.
This is how i would resolve from a programing perspective.

Here is a short vid demonstrating the problem - YouTube
as you can see on the first pass even though im playing in time i dont get what i played.
you can ignore the 2nd pass.
so as you can see I just cannot get in the groove with this issue since the 1st note is a critical part of the loop and this is always true of beats.

As you can see from the fist pass on this video - YouTube
What i play is not what is capture and makes it practically impossible to use midi to confidently record anything that places importance on the 1st note of a sequence