Timing issues

Hi,

I’ve recorded some drums on a midi track, routed to SampleTank. I then tried tracking these drums via AudioBus and IAA respectively (buffer size of audio bus and cubasis 256), but the tracked audio is notabily before the beat in each case. This can been be heard as “flams” and seen visualle as offsets between the audio and midi events.

In contrast freezing a native cubasis instrument, creates only slight “phasing” between the midi and tracked audio, indicating that they are much more alligned.

Naturally I expect the audio and midi to be in sync… Any clue what’s going on??

Hi,

any more information about your setup that could be useful to investigate on this? iOS, Cubasis version, external gear etc.?

Thanks!
RG

Ipad air 2, ios 8.3, latest versions of cubasis and sampletank, internal sound card :slight_smile:

Hi Nenox,

I’ve tried to give the issue a repro as follows (on an iPad 3):

Audiobus

  • Load SampleTank as input, Cubasis as output
  • Recorded a few bars of drums on an audio track in Cubasis

IAA

  • Load SampleTank via IAA on a Cubasis MIDI track
  • Recorded a few bars drums on a MIDI track in Cubasis
  • Performed a track freeze

In both cases the recorded (or freezed) material matches to the recordings.

Is the repro comparable to your scenario?
Did you give it a try to perform a restart of the iPad (“slide to power off”)?


Best,
Lars

I get the same issue described when Using IAA as generator. I have only noticed it since latest update, this doesn’t mean it wasn’t there before, I just never looked that closely. I noticed it because I started creating samples for MiniSampler

Scenario
Midi track with 4/4 Kick on it - MIDI OUT to iElectribe
Audio Track with iElectribe as source

Record audio onto track (using record not freeze) and with 0 MIDI Delay setting audio is ahead of midi, you can adjust the MIDI delay to line them up, but not always perfectly. and Different IAA’s give different timing difference.

What I do is record the audio and then trim the start of the file, you can then line up the audio with the Midi using snap (assuming your playing is perfect or your midi is quantised :slight_smile: )
The downside of this is that if your audio does not start at the beginning of the bar you cannot use snap to bar when moving the parts around, a workaround for this is once you have trimmed and lined up your audio, freeze the track, and then split the frozen audio at a Bar.

P.S. I’ve not looked to see what happens if your first MIDI note is right at the very start of the timeline Bar 0 Note 0, I assume that the start of the audio would be missing ?

I have observed this same problem as well-
Note I always follow “good practices” - Close apps, fresh reboot, airplane mode. iPad3, 7.1.2

First time was as follows -
Several Chordbot midi tracks imported into Cubasis - midi notes align properly to grid.
Loaded Sampletank through Audiobus inputting to a Cubasis audio track.
Recorded Sampletank.

The mix started feeling off, and on closer inspection, I found the audio tracks were all slightly before the beat. Sometimes just by a sample or two, and often by more.

I ended up spending an hour or so on experimenting with the MIDI delay setting, thinking this would be something I could set and forget. I used a couple of drum apps (as visually this made sense) and tested both with a Cubasis midi loop driving the drum machine as notes, as well as just MIDI clock driving an internal drum app pattern. I found I could get it pretty close, but after adding another recorded track the offset would change the required offset again. Sounds very similar to Andy’s tests.

What I think I’m hearing here is this problem is appearing when real time recording is coupled with MIDI. And to be quite honest, I don’t think it’s a Cubasis only issue. I recently was recording some Drumjam via it’s pads into Auria (DJ only receiving clock obviously, but it is quantized in DJ) and the same problem appeared.

I’ll try giving freeze a try when I can to see if there’s a difference here.

Andy - I suppose it’s a left habit over from my beginnings using tape, but I never start a recording on bar 1, always bar 2. In working around this challenge, this habit has proved helpful…

Hi Wigglelights,

Same here on the tape front :laughing:

as well as just MIDI clock driving an internal drum app pattern

Beware when doing this, if you run Cubasis in looped playback, with Cubasis as Clock master, then slaved apps will get more ahead of time with each iteration of the cubasis loop.

see here for previous posts on this issue http://www.steinberg.net/forums/viewtopic.php?f=183&t=72228

I ran a quick test and generated the attached screenshot.

Cubasis MIDI loop as a source -

  1. Freezing a Cubasis drum kit.
  2. Freezing Sampletank as IAA
  3. Recording Sampletank through Audiobus

Tests 1 and 2 with Cubasis running standalone (+IAA). Test 3 - closed everything, and started ST and Cubasis from Audiobus.

Note the screenshot is zoomed all the way in and high quality waveforms is selected.

As I mentioned, I’ve seen this in Auria as well when using clock to sync an audio source.

iPad3 64 cellular, 7.1.2
Clean boot and airplane mode
Cubabsis.jpg

Andy - copy that! I’ve definitely followed the many conversations around the inadequacies of midi clock on the iPad! But the loop record note is a new one to me - thanks!

The examples I was thinking of though are more related to this conversation; that as a whole these tracks/clips have consistently been “early”, any tempo drift aside.