Tip for getting Cubase to possibly play when cpu use is high

I am using Cubase 10.5.12. I have a project with many audio tracks, and a few VST instrument tracks. It has my cpu maxed out, and it often will not play with all the plugins enabled.

However, by selecting one of the instrument tracks as the “currently selected track”, Cubase will sometimes go ahead and play the project, depending on whether I have certain plugins disabled or not.

I have been able to continue working on this project, adding plugins where needed, etc., as long as I sit on a VST instrument track. Some VST instrument tracks may work better for this trick than others.

What’s your buffer size? Increasing buffer size will help Cubase playback under high CPU load but will also increase latency.

I had to finish a project using the highest buffer size available. This helped Cubase playback but I wasn’t able to play any instruments along because the latency was so bad. But by that stage I had most of my parts down so I was able to get by.

I also found that for some reason, selecting all VST instrument tracks in the project decreases the CPU load. I made a video on this:

https://www.steinberg.net/forums/viewtopic.php?f=286&t=187130

It’s hard to say without knowing the details of your project, but it definitely sounds like it’s a consequence of using asio guard. Selecting an empty track and/or turning off any monitor or record arming will affect the way asio guard treats the multi-processor threading, so it sounds like that might be what you’ve encountered.

Could be. I don’t know. My ASIO Guard is set to Low, and Multi Processing is on.

If by chance you are using Kontakt make sure you have multi-processing turned off in it. You only want one engineer for that train.

Interesting … also, make sure you have no tracks “record-armed” when not needed, to make sure you’re not using retrospective record, if you don’t need it.

Good tips, but no difference here with those.

I looked at my Kontakt VST setting and it was set to 4 cores. I have changed it to zero for next DAW restart.

But the 4 cores for Kontakt made no difference, the project will still play by selecting a kontakt instrument track.
I also have another VST instrument track, and the project will play when selecting that track.

The project will NOT play if I select a VCA track, an effect track, or an audio track (record-enabled or not).

The only thing that gets this project to play is to select a VST instrument track.

I don’t think anybody is saying anything is wrong that needs to be fixed. We’re just offering an explanation for the interesting thing you observed. It’s almost certainly an artifact of asio guard. Bussing, arming, monitoring, etc. will all have a major impact on your cpu usage.

I was just pointing out what made no difference.

Up your buffer size or set asio guard to Max.
Render the instrument tracks if possible.
Remove any heavy plugins from the master bus.

Any update on this? This sounds a lot like the internal ASIO overload issue that results from the hyperthreading issue affecting many users, many platforms, and I am following this issue.

Was this because of buffer settings or just a very large track, or did you get any resolution here?

Hi Milkman76. My buffer has been at the highest for this interface (2048). I have the latest Cubase (10.5.12).

I only made this post an assist for those that may be maxing out their DAW’s cpu use.

Cubase 10.5.20 has just been released. It might help if you could give some details of your hardware (which interface?), which version of Windows 10 (1809/1903/1909 etc.), which plugins you’re using, e.g. is it only Kontakt, which version of Kontakt, which Kontakt instruments are you using when this occurs etc. As a test, can you create a new project with the minimum of plugins that exhibits this beahiour?

Perhaps someone with the same combination could then try to reproduce the issue.

Your post gives good advice. That’s not a problem. That’s simply how asio guard works. Performance can vary depending on what tracks you have selected or monitored, so it’s good advice to pay attention to that.

I am seeing that, that’s why I pointed it out. It isn’t the kind of thing one would tend to know or think about. At least I had no idea until I stumbled upon it.

The VST instrument tracks that I tend to select in this project to make the project play are uhe’s Tyrell N6. Though other VST instrument tracks, like Kontakt, can also work.

I also find sometimes it seems to help, if the project is struggling to play, to switch to another track then back to the VST instrument track.

My Windows 10 build is 18362.

I am going to brave the .20 update and see if that makes any difference to this behavior.

Ok, so I tried the .20 update. Really not any difference to speak of in this regard. However, it ‘seems’ like checking the “turn off VST3” thing seemed to make the project slightly more likely to play.

I had a quick look at the Tyrell N6 and in the release notes (from 2015) it says ‘"we finally decided to call our current VST3 implementation “experimental”’ along with a recommendation to use the VST2 'for the time being’. As a test, can you make sure the Tyrell N6 VST3 is disabled completey, and that you are using only the VST2 version of that plugin?

To the OP: Does it also work if you select a completely empty track (like an empty audio track or unassigned midi track or an instrument track that is not playing etc)?