Tips for achieving balance between CPU and Latency?

I’m working on a really heavy project at uses a lot of plugin processing as well as Virtual instruments. In order to hear it played back correctly without any real time peaks which cause drop outs I have to run my buffer at 1024. However this causes noticeable latency when I go to record new midi parts. I already turn on “constrain delay compensation” but the latency is still way too high, which is throwing off my rhythm while recording. I need my buffer to be at least 512 (would prefer 256 or lower) but I can no longer achieve this without drop outs, which also throw off my rhythm while recording! So I’m stuck and dont know what to do.

I thought a solution would be to bounce my mix down as an audio file, put my session temporarily at 256 buffer and solo just the audio mix and the instrument I want to record. However my realtime peak meter is through the roof at 256, even though I’m just soloing only the audio track and my instrument. If I were to create a brand new cubase file, import this audio file and instrument at 256, the realtime peak meter is hardly moving and everything works perfectly. I could even go as low as 64 samples and everything works. So apparently cubase is not bypassing my instruments / effects when I solo only two tracks.

Obviously bouncing out an audio file and tempo map, creating a new cubase session, importing the tempo map and audio track, creating the instrument I wish to record, record the new midi part, exporting it as midi and importing it back into my original session each time I want to add a new part is not going to work as by the time I have everything setup I would have lost my inspiration. Are there any other solutions to this issue?

Thanks in advance for any help you can provide.

Hi JT3Jon

couple of thoughts

Preventative

  • have you got ASIO guard on? It should take care of this automatically. Play around with the different settings to see if one works better than the other
  • check your CPU is not freaking out due to some bad driver or background service. If you’re tryign to do this on a PC then I’d recommend running Latencymon to see if any of your drivers are impacting your audio latency http://www.resplendence.com/latencymon Quite often network card drivers can screw things up.
  • Again if you’re doing this on a PC run a registry cleaner such as clean and also de-frag your disks, also remove any unwanted startup programs
  • make sure you have multiprocessing turned on in preferences
  • if you’re using a usb 2 device make sure it is plugged into a usb 2 port (not usb 3)

Proactive

  • audio is much less CPU intensive than running live fx or instruments. Render/bounce each instrument and/or effect to audio and make sure you disable the original. This should release a lot of CPU :slight_smile:
  • make sure you’re not using an 32 bit plugins in a 64 bit environment - wherever possible swap out for a 64bit equivalent
  • make sure your instruments are not trying to run multi core - let Cubase do this otherwise it could lead to conflicts. e.g. if you;re running Kontakt go into options, engine and disable multi core handling
  • use fx tracks for any fx (e.g. reverbs) which you are using across multiple tracks.
  • you can use sends to apply any group processing instead of having processing on a track by track basis (e.g. compression)
  • disable or replace any high latency plug ins until you’re ready for mix down - replace them with a lighter plug-in instead temporarily if it helps

Hope something works! :sunglasses:

cheers
smapmap

p.s. there used to be a way in C7 where you could go into plugin manager and see the latency each plugin introduces. I was going to suggest you start rendering with the heavier ones first - however I can’t see this anywhere in Cubase 8 Pro? Suspect it got nuked with the recent update to the plugin manager.

p.p.s. :slight_smile: muting or soloing does not take the instrument or fx out of the chain - to remove any CPU impact you have to bypass them

p.s. there used to be a way in C7 where you could go into plugin manager and see the latency each plugin introduces. I was going to suggest you start rendering with the heavier ones first - however I can’t see this anywhere in Cubase 8 Pro? Suspect it got nuked with the recent update to the plugin manager.

Plug-in Manager

Lower left corner click on the i
“For Show Plug-in Information”

Actually you will want to switch them off completely to stop cpu use. Alt click in the rack will switch off instead of bypassing or you can of course switch off from the plug in gui.

Thanks. Missed that :slight_smile:

In this situation, you will probably find the ‘Freeze’ function very useful. It will be much quicker than manually bouncing your tracks and then switching off all the plugins on the original track.

I wish there was a way to freeze multiple tracks at once, some kind of freeze management. Going from one track to another, waiting for each to finish, is quite boring. Why don’t they make freeze manager, a pop-up window to select which tracks to freeze, and then let it do what it does?
Also, I would welcome cpu usage for each track, and then freeze just those tracks which actually use more cpu. Now I freeze track, only to see that it contributed almost nothing to cpu usage. CPU usage could be integrated in freeze management window - you see all tracks listed, you see freeze status for each track, and you see average CPU usage for each track, and you freeze away all you want.

Anyway, get real, it will not happen, I know, Steinberg couldn’t care less for such improvements… but we can dream all we want though, is it not? Maybe some other developer will read this, and integrate it in their own DAW. I see often good ideas pop up here in forum, and then soon be implemented in certain other DAW. Such fun.

That’s actually a brilliant idea

It would certainly be great to be able to select multiple tracks and freeze them all at once. I wouldn’t have thought this would be that difficult to implement.

Or render them as a “sub-mix”.

If you want to render as a sub mix this is already possible by using the ‘Render In Place’ feature (by checking the '‘Mix Down to One Track’ check box). Might be another useful option for the OP actually.

I wouldn’t recommend this. It is not necessary and asking to cause more problems.

Totally agree !!!

Windows is terrible at maintaining its registry. Fragmentation, broken symbolic links , clutter. Never had an issue.