"Toggle Accidental Visibility" doesn't include "hide"

I’m hiding and showing accidentals often (no, global Notation Options don’t solve it).

I stumbled on “Toggle Accidental Visibility” and was delighted, until I realized it doesn’t include “Hide” in the rotation. I’d use Ctrl-H, but I need to assign separate commands for both Show and Hide.

Might it be possible to turn “Hide” and “Show” into a toggle? There doesn’t seem to be a need for separate commands… if an accidental is hidden, I can press the command to show it; and if it’s showing, I can press the command to hide it.

1 Like

Dan, I have set up a shortkey to show and hide brackets around the accidentals.
May be that’s what you are looking for.
It rotates, showing the accidental, then showing it in round brackets, then showing it in the other kind if brackets, then completely hiding the accidental.
I am not at my computer, so I can’t confirm the exact order…
I have setup Ctrl+Alt+8 for this function btw.

It definitely includes “hide” here.

I just use H, and it definitely toggles Hide.

I had the same issue, just yesterday. I set a shortcut for the command named in the topic title. It works to show a courtesy accidental that doesn’t appear by default. I tried to use the same command to hide an accidental that I deem unnecessary, and that doesn’t work.

To reproduce:

  • Select a note with a courtesy accidental showing – i.e., matching the key sig, but not entered manually. It appears because the same note in the previous bar is altered from the key sig.
  • Invoke Toggle Accidental Visibility

Expected: the accidental is hidden; Actual: it is not.

Perhaps we are misunderstanding the intended functionality.

(hangs head in shame)

No, it does indeed work. Sorry for the noise, everybody.

@Mark_Johnson it works for me:

Ah, so we are talking about different things. I’m not dealing with brackets in my example.

I’m not either. The point is that it was a courtesy accidental, and I was able to hide it using a key command.

I still would like to do a toggle for show/hide that doesn’t cycle through the brackets, since I rarely use them either.

Oh, now I see! The command cycles through all the several options the more you do it! So it’s not strictly a “toggle” because there are more than 2 states. That’s what threw me.

[Comment deleted here regarding usefulness. Now I see why “Hide Accidental” is a separate command. And I had forgotten I have already assigned a key to it.]

Being still a newbie to Dorico, but methodical about using new software, when I do something and see no result, I don’t think to try it again to see what happens. So until just now I never tried it twice in a row.

Sorry for spamming; just wanted to say thanks! I had EXACTLY DanKreider’s problem. I’d already assigned a key command to Hide Accidental, then found myself wanting to Show Accidental, wondered why this isn’t a toggle, then found the perfect answer here. I agree that cycling through accidental appearance options isn’t strictly speaking a toggle function. If I were working for Dorico I’d rename Toggle Accidental Visibility as Cycle Accidental Options and change the Hide Accidental command to a simple Toggle Hide/Show Accidental. As is, it’s pretty darned good right now.