Toggle Lanes not collapsing

I can’t seem to get all of my toggle lanes to collapse. When I select a specific tracks and hit the “Toggle lanes active” button, it will either do nothing, or it will collapse that track but open up other tracks which I previously collapsed.
I’ve also tried this solution that was suggested in a previouse thread: https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/project_logical_editor/project_logical_editor_action_target_track_operation_r.html using track operation > “toggle folder open state” but that doesn’t not collapse the lanes, only the contents of the folders.

What’s going on here? I want to be able to expand and collapse lanes easily with each track I select. And also collapsing all lanes in one click would be very useful. How do I do this?

I also only need toggle lanes active for audio tracks, but it creates toggle lanes for every single instrument track in my session. It makes it really confusing and takes up valuable visual real-estate. Is there a way to make toggle lanes only apply to audio tracks?

Thank you

Hi,

When you open the Project Logical Editor and load the “Toggle lanes active” preset here, you can see, it’s just a “dump” toggle.

So the presets scans all tracks, and if there are any lanes, it toggles it’s show/hide state. If you want to apply this to the selected track only, add this to the Project Logical Editor “script”.

So the Filter Target would look like this:
Container Type is | Equal | Track | And
Property | Property is set | Event is selected

Thank you, there doesn’t seem to be a way to actually modify the parameter 2 in the project logical editor. I’m trying every option I can think of to modify it and it doesn’t seem to let me. Can you tell me how I modify it?

Hi,

If you want to add a 2nd line, just click the + button bellow the Filter Target section. Then click to the the text fields to modify them (start from left).