Toggle listening selected / whole layer

Hi, first question here…
Maybe I’m missing something, but
how do I play a layer ( start, stop ) and listen to the whole layer sound while selecting / add selection ?
I’d like to go thru the layer, mark what’s needed and apply gain
Thanks for help
and best regards

Klaus

1 Like

Hi!

If I understand you correctly, I would use the solo function. If you Solo one or more layers they “add”. Listening to one layer soloed, if you press any other layers Solo you will hear both.
A shortcut to reset/disable all solos is the master Solo button at the bottom of the Layers window.
To exclusively Solo just one layer, use CTRL+Click.

The same functionality goes for Mute - it works the same way as Solo.

Use the volume bars on each layer to set the gain.

I hope this will solve your issue, and hopefully in the future there will be an option to let Select follow Solo, so that you always have the last soloed layer active in the spectralayer edit window.

Also, in future update it would be great to be able so select multiple layers (for multi layer processing).

For stop / play you can either use the preset shortcuts, but you can of course set your own key commands (Edit - Preferences - Shortcuts) - maybe to set the same key commands as the DAW you´re working in if you use SL as an ARA2 extension!

List of the shortcuts are available online in the help section (press F1 in Spectralayer 7)

Best wishes

I only hear what’s selected ( highlighted )…
I’d like to hear the whole layer playing, while I select / add selection
?

Ok, now I think I understand better - it´s not different layers you are “selecting” but an area inside the spectral editor, in the same layer and the same audio file.

I tried this out, and as you noted it´s only the selected area that actually plays any sound - even though the playhead is started outside of the selection. I think the option to listen outside the selected area is a good Feature Request for future updates!

If you want to listen to a file, make a change in a certain area and listen to the file again you need to Deselect before you can hear the whole file.

But if you want to alter the change you made you can user Reselect to select the same area again to make more adjustments.

The selection is kept in memory until you make a new selection, so if you´re only changing the gain it´s advisable to set up key commands for the operations to minimize the risk of accidently making a new selection and loosing the one you are working on.

If you need to come back to the same area again, or just want to be sure not to loose the selection you just made, you can Save the selection. It is actually saving the audio and the time stamp, and when Loading your saved selection it will also redo the selection!

So, in short:

  1. Set up a key command in Edit - Preferences - Shortcuts for Process>Amplitude>Gain, let´s say [Shift+G]
  2. Listen to your audio file and make your selection where you want to change gain, using the selection tool. For extra safety, change from the Selection Tool to the Playback Tool after this - this will avoid the risk of making a new selection somewhere when you work on the file, and it also makes it easier to listen back.
  3. Use your key command to bring up the gain changing dialog ([Shift+G] if that was your choice) and do your change + press “OK”
  4. Deselect the area [CTRL+D]
  5. Listen again with [Spacebar], or doubleclick in the ruler at the point where you want to start listening - or use the Playback Tool if you have it selected, or by holding [CTRL] and click-hold in the spectrum editor where you want the playback to start.
  6. Reselect [Shift+CTRL+D] and [Shift+G] to fine trim your gain change
  7. Do steps 4 -> 6 until you are happy with the result, and if you need to go back to the same selection later you can Save it (“Select - Save Selection”, or make your own key command for a shortcut)
  8. Go back to step 2 again and make your next edit

If something goes wrong you can always Undo [CTRL+Z] / Redo [CTRL+Y] your steps in the history. If you are working in Pro the number of undos can be changed by the user (max 64), but in Element and One it´s max 8.

Now, I think Spectralayers big advantage is making use of the layers, so if it´s only one file you are working on there is also another way, that may be much easier:

  1. Make your selection
  2. “Edit - Cut Special - Cut to new Layer” or [CTRL+Shift+X]
  3. Change gain with the volume handle in your new layer
  4. Listen back and adjust the volume
  5. “Layers - Merge All” when you are done if you want to merge the layers into one file again.

Hope this solves your issue, and you could mark your post as a Feature Request to alert the developers!

1 Like

An additional note:

If you want to modify/trim your initial selection, to make it smaller or larger, there is no way afaik to drag the actual selections corners/sides in the spectral editor window. This is a feature request I have made earlier. You can modify the exact selection positions in the Display windows (start/length/end), but the process is highly unintuitive.

For easier manipulation of the selection, as a "step 2.5. " I´d advise you to use region markers:

2.5. Make your first selection and press [Shift+R]. Move the marker to finetune the start/end of the selection, and then double-click on the region start or end marker to adjust the selection to the marker.

1 Like

I think this answers your question, but it seems to not be working for me: Playback Tool | Spectralayers Pro 7 Tutorials - YouTube

Great response and thank you, but I think the following link addresses what he wants, but it doesn’t appear to be working: Playback Tool | Spectralayers Pro 7 Tutorials - YouTube

1 Like

Great reference video!
What was it that you had an issue with, compared to the youtube video?
I seem to be able to do what they demonstrate in the video in SL.
Best Regards! :slight_smile:

1 Like

Only the section selected with the rectangle tool plays audio even when I have the “ignore selection” option checked. The video displays at the 2:17 mark that when the “ignore selection” option is checked then the selected ranges are bypassed; therefore, playing the full audio spectrum independent of the selections. I’m using SpectraLayers Elements, but it I have the option, it is in the comparison charts and in the manual.

Ok! According to the other posts, it seems others have issues with this too.

Strange though, ignore selection is working for me! I can hear the whole frequency range when ticking the Ignore Selection box, and it seems to work the same way for all the selection tools. But for me, playback stops at the end of the selection - I can´t play “pass” the selection.

I´m on Spectralayers Pro 7.0.21(250) / Windows 10.

I hope this will be sorted out in future update, and that it will also be possible to “ignore selection” in standard play mode!

Best wishes :slight_smile:

1 Like