Toggle lower note in generating trills for Infinite Woodwinds/Brass

I have been using the infinite brass and woodwind VSTs with Dorico. The only problem I seem to come across are the trills since this VST uses a different way to generate trills. If you use the Dorico Generate trills with them, it doesn’t sounds quite right since Dorico is generating each note individually for the trill as the Infinite Series requires you to hold down the bottom note. Would it be possible to have an option in the Playback options to “Toggle lower note?” Also, since it isn’t generating the correct trill, I can’t adjust the volume mid-trill for cresc or decresc. I am still using Dorico 4 so if there is some sort of work around in 5, please let me know!

Thank you for your time.

How does Infinite Woodwinds designate a trill?

It is performance based instead of patch based. You hold down/toggle the bottom note and rapidly hit the note you would like to trill too that is above it. It works for every interval within the instrument, not just minor and major seconds. Because they are overlapping notes, it also applies the legato transitions between the notes. The generate trill feature in Dorico re-applies the bottom note when playing back. This deactivates the legato feature and makes it sounds stutter and produce a choppy sound.

Then, make sure you have the correct keyswitch linked to whole tone/half tone trills:

They aren’t sample based, they are performance based from how it is noted through midi. I have it turned off so I do get a trill sound, just the way Dorico notes it into Midi makes it sound choppy due to how Infinite Woodwind works. So if it is possible to add a “Toggle lower note” setting, that would fix this issue. I attached an example of how dorico notes trills through midi when generated and also a picture of my request to help clear up misunderstandings.
First is how dorico notates midi using generate trill:


Second is how Infinite Woodwind needs it notated:

Processing: Request Setting.PNG…

Apologies - I completely understand now. I don’t think that there’s a way to do this. Does Infinite Woodwind have a setting to change how trills are generated?

Unfortunately it does not.
I know everyone has a lot of their plate for building this program, so I am making a feature request. It’s a very niche problem so I understand if it doesn’t get implemented.

I might be completely misremembering (and my sincere apologies if I do), but I do not recall ever playing trills on Infinite Woodwinds in the way that you describe.

What I used to do was disable legato and then have Dorico generate trills, and I might have played around with played durations. I believe the legato is on by default in Infinite Woodwinds and it made the Dorico-generated trills sound like yodeling.

Your description of the sound is on point, yodeling is exactly what it sounds like!
Also your solution makes it sound a lot better, although not completely fixing the issue. By default, the trills use legato transitions, so it is not as smooth as it could be. However, it is a fairly good work-around for the issue. Unfortunately I still have to do a little work and write in the automation for the legato bypass to turn on and off whenever there is a trill. But at least there is a work around. Thank you!

Yes, I hear you… Again, it’s been a long time but I think the way I handled the legato issue was to turn it off in the instrument by default (via Natural artic) and only turn it on just for the legato itself… I remember there were a few helpful hints in the manual regarding articulations but they were not very obvious and it took several readings for me.

I tried doing this is Dorico through expression maps, however, when Dorico generates a trill, it will use whatever Legato patch is sees in the expression map. So if Legato Bypass in on by default, and you set it to turn off when you use Legato, then Dorico will generate the trill with the legato settings. So I am unsure how to get those results within an expression map. For now, I see the only way to get it to work is by adding the automation by hand.

Thank you for all your help.

If you set the natural articulation to include the CC for legato off, then I think Dorico would use whatever that articulation includes when it automatically generates the trills. You might want to also check the default lengths for natural, but I’m not sure why Dorico would be using a legato articulation for trills - this strikes me as odd. (Unfortunately, I lost a PC recently and a lot of files went with it, so everything I’m saying is from memory so again apologies if I’m wrong.)

Daniel explains that this is by default, so I am not sure how else it could be down. However, for now, it isn’t that big of an issue to just have to write some CC once in a while.

Again, thank you for your help. You already gave me a pretty good workaround.

1 Like