Too many bugs, wavelab 7 not usable (osx)

Hello,

I am a WaveLab 7.1 user on mac, and I mainly do small edits on short sample and batch apply some VST on them. But there is far too many bug in my taste to make it usable for me, especially for software paid 700 euros:

  • random crashes when rendering
  • no plugin delay compensation when rendering! come one, even free software does this… After rendering I have have a 3-7ms silence at the beginning of sounds…
  • after rendering, about 500ms of the end of the sound is silenced, if don’t untick “no tail” (which I don’t want!). fade in/out at boundaries option makes it even worse. Why???
  • the cursor jumps forward randomly when playing in loop on a short sample (after some time, the cursor loops on empty space at 45s and going forward…)

After 6 months, such issues on a critical function (rendering) is unacceptable for a soft of this cost. I quite unhappy with the steinberg support at this time and really hope these bugs will gets fixed soon, because paying 700 euros for a soft that doesn’t do its job correctly leaves a bad taste.

no plugin delay compensation

I am confident there is not bug here, this part is much tested.
Now, you may use plugins that don’t declare their correct internal delay. In that case, this is a plugin issue. This happens sometimes.
If you have a specific case, please report.

Not sure what exactly your experience with Steinberg support is, but you should be aware (as this is your first post in the forum) that the best support is right here, where the developer of the software himself answers our questions (as he did above). Oh, and welcome!

Luck, Arjan

I’m using a master section with WaveArts Panorama 5 VST and Peak Master. The rendering result in ~3-4ms delay at the start of the sound.

EDIT: I just test this same VST with Adobe Audition: no delay after rendering, and no silence problem after rendering too. So this is a wavelab issue?


What about the ~500ms of sound that gets silenced at the end after rendering? That the most annoying problem for me, do you have an idea?

Sorry, I may have sound arsh and not explained my thought well (english is not my native language): by support, I was thinking of the updates released so far, with bugs like this still not fixed may months after the initial release. Or maybe that nobody except me use the mac version of wavelab, which make it harder fo fix bugs :confused:

Thanks for your answsers anyways.

I’m using a master section with WaveArts Panorama 5 VST and Peak Master. The rendering result in ~3-4ms delay at the start of the sound.

What about the ~500ms of sound that gets silenced at the end after rendering? That the most annoying problem for me, do you have an idea?

I have now tried this plugin, and it works normally… but are you aware that this plugin adds some small reverb to the sound? The 500 ms tail you get is the reverb tail generated by the plugin itself. If you tick the option “No tail” in the WaveLab render dialog, WaveLab will ignore this tail, and you will get what you want.

Concerning the ~3-4ms at the start, I don’t see it, but this could be caused by some plugin delay parameter (reverb pre-delay stuff?).

Did you tried on OSX or Windows? I run OSX version of Wavelab.

I use no reverb/predelay, and the 500ms silence I have is when I check the “no tail” option. The last 500ms of my sound gets silenced brutally after rendering (my sound have a nice fade along its 1s length). It’s not caused by the plugin as if I play it in preview mode before rendering, everything is perfect. After rendering, the last 500ms gets silenced while my sound has still 1s length.

Same on Mac. But when you switched off the delay/reverb options on the Plugin, the plugin still tells WaveLab there is a tail (but it will be empty).
But if you set “No tail” in WaveLab’s Render dialog, this blank area is ignored.

To sum up, you face a plugin behaviour, not a WaveLab issue.

Then why the exact same plugin with the exact same settings works perfectly well with Adobe Audition? (i’m yet to try it with other soft to prove the point). No extra delay at start and so 500ms silenced part at end when rendering.

And I’m not saying that 500ms of silence is added to my sound, but that 500ms of my sound that is no silence gets “cut” or silenced after rendering on wavelab.

To really compare results, try with a sine wave samples generated from the WaveLab tools menu. Then do screenshots.

it seems I’ve found the culpirit for the 500ms cut problem:

  • I did tests with a 5s sine wave as you said, with default presets:
    -> no delay at the beginning (seems it was my settings that were causing the delay
    -> a ~300ms silence at the end.

Removing the peak master plugin remove the 300ms silence at the send.

Then it’s the peak master plugin that seems faulty. As it was included in the standard bundle for years I never imagined it would be the culpirit… Is it something that may be fixed in a future update or integrated plugins aren’t updated with wavelab releases?

EDIT: Still not there. The peak master is not really the culpirit it seems. As long as I add a VST in the chain after Panorama 5 I have this silence at the end :frowning:

EDIT2: I have done more tests:
When you add certain plugin after Panorama 5 in the chain, you end up with this small part of sound silenced at the end. Seems that it occurs only with this plugin. Panorama 5 alone in the chain does not result with this silence.

For example, it occurs with peak master, all sonnox plugins, limiter, compressor, deesser, and others.
But it doesn’t occur with resampler, leveller, chorus, other wavearts plugins…

That’s quite strange. This issue still doesn’t exists in Adobe Audition.

Now, I can reproduce something wrong, if the following combination is found:

  • A VST reverb plugin like Panorama (reverb plugins are not like other plugins, because they may have a special ‘tail’ parameter).
  • Must be followed by a VST plugin that has itself an ‘internal’ delay
  • Mode “No tail” must be active.

That is not such a common situation, as this bug is also in WaveLab 6 (and earlier I guess), and it was not reported before.

I will try to solve it for WaveLab 7.2

Thanks for the report.

I’m relieved you were able to replicate this one.

I have found another annoying bug:

  • generate a sine of a 500ms duration
  • put only Panorama 5 in the chain, default preset
  • render options: fade in/out on, bypass on, no tail on

When processing in place, no problem.
When rendering to file, the last ~150ms are silenced. :frowning:

Exact same thing, but rendering to file instead of rendering directly in place cause problem.

Thanks. I can reproduce too, with the same kind of plugins.
This will be fixed in 7.2 (not in the soon coming 7.11).