tool modifier timestretch doesnt snap correctly

go to prefs, tool modifiers, size objects

set any modifier key like CTRL, ALT etc for time stretch

try it and you will notice it doesnt snap correctly to the grid.


By default, the Ctrl modifier is set to enable/disable Snap. So if you choose any modifier with Ctrl, the Snap is disabled temporarily.

Thanks for replying but your comment doesnt really make sense as you can only select CTRL once in this row. Disable snapping will be gone then. Disable snapping is now ALT in my case. I understand your point but just try to reproduce it…



I have chosen Alt modifier, if I would choose Ctrl, the Snap would be overwritten.

Then I made sure the Snap is enabled. And I hold down Alt modifier file Time Stretch. The Audio event has been stretched and snapped to the Grid here.