Top Tips for MusicXML import

Like many of you, I’m importing lots of old projects from other software into Dorico. Of course, I want to benefit from Dorico’s engraving, so I keep most of the XML import preferences turned off.
However, I don’t want Dorico to alter the note groupings and durations, so I checked the box for Note Durations. But Dorico was still splitting some notes! Argh.

I’ve worked out the problem. If I have this pattern:

Dorico still splits the syncopated crotchet over beat 4, despite the import settings.

But I’ve discovered the reason! It seems that Dorico’s beaming rules take preference. If I keep the Beam Groups checked as well, then I get my notes exactly as I want.
Screen Shot.png
Screen Shot 1.png