Track Control Settings function crashes Cubase 9.0.3

This is consistent and happens every time I try to access Track Control Settings, wether right clicking on the track or using the wheel icon in the lower left of the interface.

  1. Open Cubase and insert an instrument track
  2. Right click on track header and select Track Control Settings… (or slick on the Track Control Settings button)
  3. Cubases crashes out

2016 iMac i7, 24 gigs RAM
OS 10.13.3
Cubase 9.0.3 (build 266)

Please help, this bug is killing me right now…

here is excerpt from the crash log if it is helpful:

Process: Cubase 9 [34875]
Path: /Applications/Cubase 9
Identifier: com.steinberg.cubase9
Version: (
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Cubase 9 [34875]
User ID: 502

Date/Time: 2018-02-07 15:31:27.331 -0800
OS Version: Mac OS X 10.13.3 (17D47)
Report Version: 12
Anonymous UUID: 37B56EA6-A741-F345-E01B-D918EFEE1BF1

Sleep/Wake UUID: 300A621E-B3A6-4AA8-A5B6-1A2A2D982435

Time Awake Since Boot: 100000 seconds
Time Since Wake: 9200 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

VM Regions Near 0:

__TEXT 0000000106bab000-0000000109a54000 [ 46.7M] r-x/rwx SM=COW [/Applications/Cubase 9]

Thread 0 Crashed:: Dispatch queue:
0 com.steinberg.cubase9 0x0000000107a7f57e 0x106bab000 + 15549822
1 com.steinberg.cubase9 0x0000000107a7f13c 0x106bab000 + 15548732
2 com.steinberg.cubase9 0x0000000107ac006f 0x106bab000 + 15814767
3 com.steinberg.cubase9 0x0000000107ac4e48 0x106bab000 + 15834696
4 com.steinberg.cubase9 0x0000000108581c6a 0x106bab000 + 27094122
5 com.steinberg.cubase9 0x0000000107d5fdac 0x106bab000 + 18566572
6 com.steinberg.cubase9 0x0000000107d064c6 0x106bab000 + 18199750
7 com.steinberg.cubase9 0x00000001085841ee 0x106bab000 + 27103726
8 com.steinberg.cubase9 0x00000001087e1d83 0x106bab000 + 29584771
9 com.steinberg.cubase9 0x000000010856fdcd 0x106bab000 + 27020749
10 com.steinberg.cubase9 0x00000001085c62d8 0x106bab000 + 27374296
11 com.steinberg.cubase9 0x0000000107d93aca 0x106bab000 + 18778826
12 com.steinberg.cubase9 0x000000010871b5a4 0x106bab000 + 28771748
13 com.steinberg.cubase9 0x000000010871d677 0x106bab000 + 28780151
14 com.steinberg.cubase9 0x000000010861fef0 0x106bab000 + 27741936
15 com.steinberg.cubase9 0x0000000108581b5c 0x106bab000 + 27093852
16 com.steinberg.cubase9 0x0000000107d5fdac 0x106bab000 + 18566572
17 com.steinberg.cubase9 0x0000000107d064c6 0x106bab000 + 18199750
18 com.steinberg.cubase9 0x00000001085841ee 0x106bab000 + 27103726
19 com.steinberg.cubase9 0x00000001087e1d83 0x106bab000 + 29584771
20 com.steinberg.cubase9 0x00000001087de78b 0x106bab000 + 29570955
21 com.steinberg.cubase9 0x00000001087de00a 0x106bab000 + 29569034
22 com.steinberg.cubase9 0x00000001088103c2 0x106bab000 + 29774786
23 com.steinberg.cubase9 0x0000000108810b13 0x106bab000 + 29776659
24 0x00007fff3cf30029 -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 5040
25 0x00007fff3cf2e85c -[NSWindow(NSEventRouting) sendEvent:] + 497
26 0x00007fff3cd8ffa3 -[NSApplication(NSEvent) sendEvent:] + 2751
27 com.steinberg.cubase9 0x000000010841e38f 0x106bab000 + 25637775
28 0x00007fff3c5f0d9d -[NSApplication run] + 812
29 com.steinberg.cubase9 0x00000001087fbd7e 0x106bab000 + 29691262
30 com.steinberg.cubase9 0x000000010862b54d 0x106bab000 + 27788621
31 com.steinberg.cubase9 0x000000010841880a 0x106bab000 + 25614346
32 com.steinberg.cubase9 0x000000010841d93b 0x106bab000 + 25635131
33 libdyld.dylib 0x00007fff6692c115 start + 1

Thread 1:
0 libsystem_kernel.dylib 0x00007fff66a7c562 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x00007fff66bb726f _pthread_wqthread + 1552
2 libsystem_pthread.dylib 0x00007fff66bb6c4d start_wqthread + 13

no responses on this??

I deleted pref and opened with fresh settings and it still crashes.

Just started in safe mode and it still crashes!!! WTF? Any clues will be most helpful.

Must be a corrupted file somewhere. Don’t know what else could be causing this. Any tips on what to try next would be very helpful…

any ideas to try?

Sorry i can’t help, as i am on windows. Seems you might need a re-istallation.

PS With windows 10 64bit some of these type errors are GUI related; f.i. latest Wavelab 9.5 vesion only runs in compatibility mode for an older Win-OS version. It has problems with only a certain plugin, took me a while to figure this out, seems related to USB, my graphics card and ONLY on my system too LoL. I read somewhere that it’s the same is for Cubase 9.5. - F

Thank you fiddler2007, that’s a clue. I wouldn’t have imagined it could be related to USB being a setting within Cubase! At least I have something to try. thanks! Though it crashes even when I load Cubase in safe mode.

I thought about updating to 9.5 but there is no guarantee that it would fix this issue.

Why i am waiting for the next version of 9.5. On my system 9.0.30 seems quite stable. BTW if you’re on MAC, why don’t you use Firewire instead of USB. Windows 10 is not very Firewire friendly, so i had to change to USB; still have a mint RME UFX for sale, i miss the stability and low latecy i had with Firewire on Windows 7 LoL. - F

I’m on a newer mac so I don’t have firewire access any more. I unplugged all the devices on my system and it still crashes

This is exactly what I needed. Thanks for the idea! I bit the bullet and decided to completely remove everything Cubase and Steinberg and re-install. Took almost 4 hours to re-download and re-install everything and make sure I saved my settings file to restore. But, it worked!!! damn, what an ordeal. Wish I knew what caused this. From one day to the next it started crashing even in safe more. I guess there could be on little file with corrupted data or something? Who knows!!! ?

Deleting user preferences.xml in the folder

Mac: ~/Library/Preferences/Cubase X
Win: %appData% Steinberg/Cubase _X__64

worked for me. Everything is fine again.