Track Length Change when Saving as MP3

Hi Everyone,

I’m working on a project where I need to create 8 hour mp3s of sleep-aid audio. When I Save As and choose MP3, the resultant audio file comes back at 7hrs 59min and 16sec. Every time.

I then tried to export this project as a wav file, thinking to convert it later, and it exported it only to 1hr10min.

Can anyone shed any light as to what might be happening? The track must be exactly 8 hours. My source track which is a series of 2 hour sections copied and pasted into a new audio file - is exactly 8 hours long.

I can’t quite figure this out - any help at all would be greatly appreciated.

I’m running Win7 64bit, 16GB RAM, i7, WL 7.2.1

Many thanks!!!



It’s about the MP3 encoding (header and footer in the MP3 file)
do this create a wav 10 seconds
encode to MP3
now zoom in on the Mp3 in WL
at the beginning and the end of the MP3
you should see a few 20-30 ms at the very start
and the same at the end of the MP3

so get a MP3 that is exactly in samples/ or in time
I don’t know if this is possible !?

and about the MP3 to wav, you need to save in Wave 64 or RF 64 format
check Audio Files editing preferences or Recording dialog / Audio format

regards S-EH

The answer of S-EH, who usually applies for this kind of question, should not be the right answer in this case, as 44 seconds are missing. But I don’t have another answer, and it’s the first time I hear about a 8 hour mp3 case.
does some part of audio is missing? If yes, where?
What is the source, a montage, or a wav file?
What sample rate?
What mp3 encoding?

Oops sorry yes PG is right 44 second is alot but 8 hours is alot more :wink:
I just didn’t read closely and just answered away thanks for correcting me !
and the MP3 encoding is there for sure so maybe it will build up ( the header footer info in MP3)
when you have a recording as long as 8 hours ?


regards S-EH

In proportion it is quite similar to the figures you gave in ms for a 10s sound (within a factor of two). However, when I made an mp3 of a one-hour file just now, it was 30ms longer than the original - I presume therefore that it works in some unit of timeframes.

Are you using the Fraunhofer or Lame encoder (I use Lame)?

This is 70 minutes, and probably (looks like it) the limit set in your preferences as maximum CD-Audio length. Do you have CD markers set in the montage? And like S-EH says, you need to use Wave 64 or RF 64 format to create such long wave files (intricate limit of the Wave format).

Hey thanks everyone!

I’ll examine these replies when I’m back in the studio tonight and answer the questions posed by Philippe, and take a closer look in preferences.

The 8hr files are for sleep therapy products I’m creating for a client.

Your help is very appreciated!


Also answer the good question from pwhodges:

Are you using the Fraunhofer or Lame encoder (I use Lame)?

Hello everyone -

Here is my exact workflow:

Create a new stereo Audio File, 16bit/44.1. I open a 2 hour 16bit stereo audio file, verify to the 1000th of a second that it is exactly 2 hours long - audio from 0 right to 2 hours. Select All - Copy - Paste into the Untitled tab. I deselect the newly pasted clip, press End to get to the end of the pasted audio, and paste again. I do this 4 times, verifying that the audio is perfectly ending/starting each 2 hour “snippet” without any gaps or breaks. After 4 times, I have an 8 hour audio clip - still Untitled as I haven’t saved it yet. I do not need a .wav version of this, so I will go straight to the MP3 creation.

Last time I simply chose Save As from the file menu, but I didn’t note all of the things I did to arrive at the mp3. I just did it again, and this time I chose to Render the clip into an mp3. I used Frauenhoffer, 96kbbps. The resulting mp3 is 7hr59m16s938ms

I’m not using CD Markers in the audio file - and I’m not using the Montage feature to create this.

Here’s something interesting - the reported time length above was obtained by hovering the mouse over the new mp3 in the File Browser in WL. When I actually open this mp3 in WL, it shows on the time ruler as 8h52ms. So this is MUCH better.

My apologies everyone - for wasting your time. I’m not sure I understand the math behind why 8 hours of audio is more/less when converted to mp3, but I can live with 52ms. 44seconds was a bit too much - but I hadn’t actually opened the file.

There still may be an issue between the time report from hovering over the file in the FBrowser vs actually opening it… but for now I’ll leave this issue. I’ve got a dozen or more of these to create so I’ll keep an eye on it and make sure that I’m getting similar results - and will report back if things aren’t consistent.



I see. Since there is no header in a mp3 file, the time displayed in the file browser is an approximation. The real length, you have it: 8h + 52ms. Then you are safe. For the 52 ms, get back to Sven’s original answer :slight_smile:

Thanks PG for correcting me :wink:

and yes I’m not a programmer thats why the header info
is a wrong word/description of the encoding of a MP3 I think
more correct wording MPEG Audio Frame Header
but I was going by the fact of why is a MP3 not exact in time/samples
and try to explain with my homebrew wording’s, sorry

check here:

if this info is not correct then just trash it, puh :slight_smile:

regards S-EH

Well, many thanks to all of you for your help on this. Learned a few things here - most importantly, provide ALL of the details in my orig. post. If I’d mentioned I had been using the File Browser hover info for my time assumption - I’d have saved all of this trouble.

Much appreciated you guys! Thanks again,