track quick control issues: address automatically changes to 0

Hi guys

I have a Novation Launchkey 25 mk2. I connected it to Cubase 10. The keys work well. I can record notes and move tracks using the keyboard. However, when I use the quick control to let the knobs control expression parameters, it doesn’t work. The problem is: in the Track Quick Control interface, when I tick the Learn box and turn the knob, the address of Quickcontrl1 first changes to 64, then it automatically changes to 0 when I stop turning the knob. I don’t know how to make the knobs work.

It drives me crazy. Please help. Thank you!

There is some other weird signs worth mentioning. The midi indicator in Cubase 10 pulses every second. I also need to press the keyboards with extra force otherwise the sound is very low. I don’t whether these are normal or not.

Ryan

Update:
I have tired assigning CC to the knobs in Kontakt and everything works just fine. So I guess my Novation Launchkey 25 mk2 is ok. I still don’t know how to make it work in Cubase 10. I am currently downloading Cubase 9.5.

Update: I just tried Cubase 9.5. Doesn’t work. Same problem.

Update: everything works fine in Ableton, but not in Cubase. Help please.

update: I tried installing Cubase 9.5 in a brand new laptop. Still doesn’t work. Same problem.

It sounds like something is not set right perhaps in the keyboard? After the control is learned, did you turned off the Learn function and then hit “apply?” The values should get locked in and be available on any track using Quick Controls.

This can be a frustrating part of the program and there are many threads on similar issues. Check posts by Brian Roland in the 9.5 forums on Generic Remote.

Sorry I can’t offer an immediate solution. Usually, with some effort and frustrations, this part of Cubase will work.

Hi Stephen!

Thank you for the reply. It worked (against my expectation ha!). I didn’t turn off the Learn function and then hit ‘‘apply’’. These two steps turned out to make all the difference.

But can I bother you with another problem? These knobs now work well, but they can only increase value. When I turn the knobs counter-clockwise, the values increase gradually. When I turn the knobs clockwise, they would immediately set to zero. Any suggestions on what is going on here?

Thanks again for your reply. It released me from hell :slight_smile:

Ryan

Check:

  1. Preferences > Editing > Controls > Knob Mode. (I use linear mode for my Advance 49 and it works).
  2. In the Generic Remote set the “Flags” for the Quick Controls to R,T,R (Not forgetting to do “Apply”).

I’m not sure this will work for your Keyboard, but these settings do work on my Akai Advance (which is a very basic controller).

Once you have the GR working reasonably well it’s best to save it. Then, Reload it, hit “Apply” and you should avoid it not being reloaded with a new project.This happens sometimes and can be very confusing and frustrating. GR is an archaic part of the program. Requests for improvements have been made. Those have, so far, gone unanswered. For now, this is what we have.

Good luck. :slight_smile:

Hi Stephen

I have tried your suggestion. Unfortunately, it doesn’t work for me :frowning:. Turning the knobs counter-clockwise just won’t work.

The keyboard works well in Ableton though, so maybe its not the keyboard’s problem. Maybe there are some settings in Cubase that I have missed, but I really don’t know which. Cubase looks so complex to me.

Kinda worn out by this.

Ryan

Hang in there. This part of Cubase can be kind of annoying. I had a quick look at the Novation website and perhaps there’s some help for you there, or from the Forums over there.

https://support.novationmusic.com/hc/en-gb/articles/207561535-VIDEO-Launchkey-Cubase-Setup

Good luck working it. I have a feeling you’ll get this locked in. The Preference settings I mentioned are what works on my system. Perhaps you need to set the “Flags” to different values in the Quick Controls – try just R,T and leave off the “Relative” setting – not sure. I’d talk to the Novation side and see what they know or other Novation users. It looks like cool Controller.

Don’t forget to hit “Apply” after each change. It’s very easy to start chasing your own tail when working on this.