Track Quick Controls Activate question

Somehow I’ve managed to never need to use Track Quick Controls, until now…

In the Inspector’s Quick Control Tab there is a button to “Activate Quick Controls” which doesn’t seem to do anything that I can tell. Initially I assumed if it was on the QC would work & if it was off the QC wouldn’t work. However if the button is off and I move the knob assigned to a QC on my controller I see the value change in the Inspector and I can both see & hear the parameter change on the VSTi - exactly the same behavior that occurs when the button is on.

I’ve also noticed that when I turn the button on (or off) it also gets turned on (or off) for every other Track.

Can someone explain what’s going on?


You may be confusing Track Quick Controls and VST Quick Controls. Have a look at that.

No, I do mean Track Quick Controls. If I move the assigned knob the value in the QC Tab in the Inspector is what changes, nothing changes to the VST QCs in the Instrument Rack.

In the attached you can see that the Activate button is off. But the 1st QC, which was initially 0, is now 31. That change occured when I rotated the assigned knob while the button was off.

The Activate Quick Controls button only controls whether they’ll respond to your MIDI controller/remote device or not.

Ok, that’s how I thought it should behave. But it is responding to the controller BOTH when the button is ON and also when it is OFF.

Here’s a gif showing it occurring

Just had a play around - yeah, the on/off switch doesnt seem to do anything.

I’ve chased my tail around and around at times over this and sometimes still do. Check this. On the VST Instruments panel, make sure the little (nearly invisible) circle on the Lower Right of the instrument is either On or Off. If it is On then the focus is on that instrument and the QCs will respond to that instrument, if it off, then the QCs are free to perform their assigned functions per generic remote settings. I’m not sure this will help sort things out here but it might.

Adding: The QCs can also be assigned to many things other than the defaults. So, for example, you want to have control over the Send Level to Aux 4 of HSSE or something else. Then, the QC being on or off will make a difference, and you can shift the Focus to the VST Instrument or the QCs.

There’s VST Controls and Track Quick Controls and then how all that fits into the Generic Remote, if you’re using GR.

Stephen has explained it very nicely here. You probably have Track Quick Controls and VST Quick Controls assigned to the same MIDI CCs and are ACTUALLY controlling with VST Quick Controls even though the Track Quick Controls are “turned off”. Since the Track Quick Controls are assigned to the same parameters they are also responding. My initial response to make sure you are not confusing Track Quick Controls with VST Quick Controls was not a good explanation because I was on a tablet at the time and hate typing long messages on it. Again, thanks to Stephen for an excellent explanation.

I was 99% sure that’s not the situation (and am now 100%).

I assigned a Track Quick Control to a parameter totally unrelated to any potential VST Quick Control, the Send Level to a Group Track. As you can see in the attached GIF, the level can be changed when the Activate button is both on & off.

I tried using an Audio Channel Send. I assigned the Send Level to a Track Quick Control. If I turn the Activate button off, the level does not respond to my controller. If I turn it on, it responds. I am trying it with an instrument send to see if I can reproduce your situation.

OK. I just tried it with a send from the instrument channel of a Kontakt instance and It worked correctly. If the Activate button is OFF, the parameter does not respond. If I turn on the Activate button, the parameter responds to the controller input.

One way to test would be to go to Device Setup… VST Quick Controls and where it says “MIDI Input” select “Not Connected”. If the parameter stops responding to the controller with the Activate button off, then that would mean it was coming from the VST Quick Controls somehow. If not, then it must be coming in somehow. I would really like to figure it out. :slight_smile:

Do you have that same device setup in some other interface such as the Generic Remote or Automap or something like that? It could be that it is being sent via another means such as an Automap assignment, etc.

Good debugging idea, although the results are puzzling. I’m using a Steinberg CMC-QC as the controller and I’m starting to think its configuration is corrupted. First I set VST QC input to “not connected” which had no impact.

However there are 2 Remote Devices that are getting their input from the CMC-QC. One, as expected, is Track Quick Controls. The other is called “Steinberg CMC-QC” and it is used to have the buttons on the CMC control the Transport. If I disconnect the input on both of these Remote Devices turning the knobs doesn’t change the Track QC values - again this is what I’d expect.

But now it gets odd. If I connect only the input for Track Quick Controls, now when I turn the knob down it sets the value to 65 and when I turn it up it sets it to 1. This seems to me what I’d expect to control a button & not a knob. And if I only connect the input for the Steinberg CMC-QC Remote device (which should control the Transport) it sends out continuous data between 0-127 - what I’d expect for a knob & not a button. So something is messed up between the 2 Remote Devices leading me to suspect data corruption.

In every case if the controller is changing the value at all, it will do that with Activate on or off.

I’ll try reinstalling soon & report back.

Could someone who has this all working correctly check and see if you change the off/on state of Activate QC on one Track does it change the state on all Tracks. That’s also happening here & seems wrong too.


While I can’t say things are “perfect” in my set-up, one of the things that is generally working well is my Generic Remote (bowing to Brian Roland for his invaluable help on this) and my GR settings integrate (for the most part) just fine with the both types of Quick Controls, track and VST. I’m able to use instrument controls and separate controls for the track, I can swap banks in the GR and the Track Controls functions change correctly. I do have to remember to turn on/off the Instrument Controls (VST Instruments Panel) and the same for the Track QCs. All this was a major breakthrough for me and has made using Cubase a lot more like a “real studio” – more buttons and knobs, less mouse, less qwerty keyboard. I’m thinking there may be some hardware issue? Maybe a bad cable? I’d check with MidiOX to see what is being sent perhaps? It sure can be a time-consuming process to sort out these kind of issues. :cry:

Also, it may be time to think about resetting Preferences (once again) as a possible quick fix. While I hate doing that it does often correct erroneous behaviors that show up. What I can say affirmatively is that I’m not having the problem your posts demonstrate. Good luck with this, I hope it gets worked out.

This is also odd, I notice in the gif file that when the values are changed they do not match during the change, but, the end points do line up. When the control is moving, however, they seem not to. Is this a problem with the Gif file itself, or is that what is happening? If they are not matching when you move the control then my guess (and it is a guess) is that there’s some sort of error. If this is just a gif animation issue, then disregard. :confused:

I have never used a CMC and this is an educated guess…
I see it has a “MIDI” button, which I assume allows it to function like a standard MIDI controller. In it’s normal mode it probably uses a software driver or “interface” (there is probably some file in the “Components” folder of the Cubase installation tree) that makes this happen. It may be similar to my current controller, the Axiom Pro which uses a thing called “HyperControl” but can also work in standard MIDI mode. The HyperControl can be very powerful, but is dependent upon the software “driver”. Waiting for updates for these drivers as different versions of Cubase were released were long and painful and eventually stopped. Currently, I am using the Cubase 6 version of HyperControl “personality”, which, luckily works for most features but not the VST Instrument and Effect editing. I think manufacturers are moving away from this type of programming and towards a more standardized type of interfacing like the Mackie mode or HUI mode, which is probably why the CMC controllers are discontinued. Anyway, my guess is that the problem lies somewhere in the interface between the CMC and Cubase and it may be communicating of multiple “channels”. You could try removing that .dll file (I don’t know what it would be named but it may be obvious) in the components folder and trying a generic MIDI mode just to see what happens. Or, reinstall the CMC software on the chance that there is an error. Is the software and firmware for the CMC up to date?
Lastly, it may not be worth the trouble to try to fix the original issue.

This is becoming more & more likely.

I don’t think you mentioned (quickly viewed the thread) that you enabled the midi settings for QC for your midi controller (turns it on for the selected controller).
Device Setup>VST QC.

Since it’s from Steinberg the CMC series are configured for integrating with Cubase when you install them. Out of the box a set of buttons determine what the CMC-QC controls. You can change it between Track Quick Controls, EQ, etc. on the fly.

I uninstalled & reinstalled the CMC software (which was at the latest version) but the problem remains.

At this point I think I’ll just ignore it rather waste more time trying to debug it. I can effectivly turn off the Track Quick Controls by setting the CMC-QC to control something different like EQ (where it typically lives) instead of in the GUI. Basically the GUI button says “don’t listen to any QC data you hear” while turning it off on the CMC-QC tells the controller “don’t send out any QC data.”