Track/VST Quick Controls inactive 'Apply' button

I’m trying to connect my remote control through the Track or VST Quick Controls. Using ‘Learn’, I’m applying to set QuickControl x to the corresponding settings on my X-Touch Compact. So the first QuickControl is looking at MIDI Channel 8 Address 1 and so on. I would expect that after completing my setup the ‘Apply’ button at the bottom right of the dialog would be active, allowing me to put my setting into play. It remains grayed. My ultimate objective is to use the X-Touch Compact to record CC messages to the selected tracks. The odd thing is there are times I’m able to use controls to record on the animation tracks. I don’t have a clue how, but it works. Most of the time it doesn’t. And each time I open the project I have to start over with settings. Can anyone think of something I may be missing that’s disabling the ‘active’ button in Track Quick Controls dialog?

Thank you


Cubebase 10.5.20
Windows 10
Behringer X-Touch Compact Controller

Hi,

The Apply button is not necessary anymore. The settings is stored immediately.

Unfortuniatly, that doesn’t help. The CC signals are not making there way to animation channels even though the Quick Controls seem to be seeing them.

Hi,

At the end, do you want to record MIDI Controller data or do you want to control some DAW/plug-in parameter on the track?

If you learn the assignment to the QC slot, you switch to other Remote and back, does the QC assignment remain?

The objective is to open a lane in the lower panel, or lane off the instrument tracks, and record CC1, CC7, CC11 and so on. I’m using X-Touch Compact as the controller. Cubase doesn’t have a problem seeing X-Touch, nor is there an issue with Cubase to ‘Learn’ which control on the device is sending which CCx message. The problem is getting that message to be heard by the annotation channels or lanes.

Is this what you’re looking for?

Hi,

Is the Learn mode enabled? Do you have the right right MIDI Input selected? Is the QC slot selected (in the Studio Setup window)?

MIDI input and output are correctly set to X-TOUCH COMPACT.

Learn is checked when I setup the MIDI channels. That part of the process is working. MIDI Channels and Addresses are being set as they are defined on the device.

I’m not sure what you mean by QC slot? If your referring to the Control Name, they are set to QuickControl 1, QuickControl 2, etc. MIDI Status is Controller.

Hi,

Could you please make a video?

Setting channels 8,7,6. Short version. Long version. Did you need more?

https://www.dropbox.com/s/vv4mu57f6rbe8ej/Studio%20Setup%202020-09-03%2019-58-02.mp4?dl=0

https://www.dropbox.com/s/tofbnr1p6sbzdfk/Cubase%20Pro%20Project%20-%20Monet's%20Garden%201.2%202020-09-03%2020-14-37.mp4?dl=0

Hi,

Sorry, there is no sound on the videos, so especially for the 2nd one it’s hard to guess what you are doing. But…

As I can see on the 1st video, the Quick Controls assignment is done correctly.

From the 2nd video, I guess, you want to achieve something where you don’t need Quick Controls. Do you want to record MIDI CC7 (Main Volume) to the track? Then you don’t need Quick Controls. In this case, you have to set the QC Input and Output to Not Connected in the Studio Setup window, otherwise all MIDI CCs are filtered out by the QC from this device.

I get it now. No Track/VST Quick Controls are needed. I set them to ‘no connection’ and was able to record the annotation in the lower zone.

If I may bother you with one more question. When I record the annotation channels, it doesn’t replace the old messages. Instead, it adds it. That can get quite odd. I’m not finding on the Automation Panel or the MIDI Controller Automation Setup screen that will enable the new recording to replace the old. I find myself having to ctrl z if I’m to re-record or select and delete the old messages if I’m starting over. Where do I look?

Hi,

Do I understand you right, you are recording MIDI CC values as automation and you have some MIDI CC recorded in the track already? If this is the case, have a look to the MIDI > CC Automation Setup, please.