Transport item Cubase AI 7 elements

In the post http://www.steinberg.net/forums/viewtopic.php?f=209&t=60241#p421113 a solution is mentionned for my problem with my midi keyboard Asturia Keylab19.

Open in Cubase Transport > Project Synchronization Setup > Machine Control Input section
Click “MMC Slave Active”
In MIDI TimeCode Source Section and select your Keylab Keyboard
MMC input : ALL MIDI Input
MMC Device ID : 127

However the option MMC Slave active is not available. Should an upgrade to 7 Artist guarantee a solution?

Greetings,

Lucas

Hi and welcome,

  1. I would recommend to set MMC Input to All Devices. I would recommend to restrict it to the Keylab only.

  2. Is it the synchronization really needed? It sounds, like Keylab will control the tempo of your project, and Cubase will be a slave.

Thanks a lot for your quick answer, Martin. My problem is that I cannot control with my version of CUBASE the knobs on my keyboard, using the Remote Device
Play, rewind, stop, pause. The learn function does not respond to my interaction with these transport knobs on my keylab.
The above reference suggested this solution for people with similar problems.
Meanwhile I will try out your solution. Thx again!

Hi,

Do you know, which MIDI messages do theese buttons send? Can you check it in any MIDI Monitor software (or directly in Cubase MIDI track and MIDI Monitor Insert)? If it really sends SysEx, then I’m afraid, there is no other way then to use the MMC. But I hope, it sends some “normal” messages, like MIDI CCs.

In the operation manual, there is this: Buttons send standard MMC messages: Start, Stop, Record, Rewind, Fast Forward and Loop. They can be customized in the MIDI Control Center.

So it seems, they really send these SysEx. But I would recommend you to modify them. Then, you can use standard Generic Remote Device.

I went with all my gear to the Keymusic shop in Ghent. So :

  1. Forget all aboout MMC (as mentioned before) Cubase AI 7 hasn’t even this MMC Slave checkbox. Anotyer post mentionned an upgrade to Cubase Pro. Don’t do this if you only would tackle this problem.
  2. Open the Midi Contol Center (on Windows you have to first close the DAW)
  3. Make a template (fe. name : cubase)
  4. Select the zone with the transport knobs
  5. Select the transport-button on screen (fe. Play)
  6. Change Mode to Control and channel fe. 16
  7. Do this for all transport knobs (stop, record, …)
  8. Export your setting using the File > Export function (for later use on other computers)
  9. Synchronise

From this moment this functions on this channels are available for the DAW


10. Open Cubase and perform the steps from of https://www.youtube.com/watch?v=DeNyL136b64
11. Don’t forget to export the remote device script (otherwise the settings will be lost for the next session!)

Thanks Martin for putting me on the right track.
Thanks Mr. X from the Keymusic-shop (seller of Arturia and many other keyboards) in Ghent for finding the solution, despite your defensive mood (“this is problem of Cubase”, “Cubase is to complex”, “don’t interfere with your questions while I’m searching for a solution”, …). I know : old dummies are difficult clients.:slight_smile:) But at he end you seemed happy to find the solution. I observed even a little smile. Congratulations.