Transport not always working when files open

Hello

I’m composing a score with around 12 players; 20 instruments. For various technical reasons (concerning effects that are also being controlled continuously in the score) I have samples for the instruments in an external DAW.

I’m using Dorico Play to send midi out to these virtual instruments (and to the effects).

In general it’s all working smoothly but I have one recurring problem I can’t solve:

When I open a file, even though there are no VST instruments called up within Dorico itself, the transport buttons are faded out and unusable - so I can’t play the file. This occurs even though the ‘active project’ button is on - and even if no other projects are open.

I have to have several goes at toggling the active button, switching the sound card off and on again, changing then resetting the sample rate, opening and closing the file again, pressing the spacebar repeatedly with pauses in between - anything that might trigger the buttons to become active again. Eventually, after a few random combinations of the above, the transport springs into life. But I’d like to know how how to fix this. I’d like to get past this mysterious issue immediately on opening a file.

Sometimes the sounds themselves are active and the midi out is working - I can hear individual notes when I click on them in the score - but the transport still won’t advance.

Is there something obvious that could fix this? I’m using a Mac M1 and a Fireface UC soundcard. Everything open on my machine is working at the same sample rate (48kHz).

…on a cheery note: the piece I’m writing is making use of the tabulature + staves as I’m writing for a 7-string gamba with scordatura and that’s working out a treat. So is a live electronic effects line which I can audition by sending control signals to my other software (Max or Abelton) using Expression Maps and CCs. This has been a huge help with this score.

Thanks

Sarah

PS I’m using Version 4.3.0.1110 (Nov 13 2022). I see there’s an update but am reluctant to download it as I’m on a deadline and can’t lose a day if it doesn’t go to plan.

The transport will become enabled when Dorico thinks all of the virtual instruments in the rack have been loaded. I wonder whether the fact that you’re using entirely MIDI-based endpoints rather than VST-based ones could be making it go wrong somehow. Can you try adding any VST instrument to the rack, it doesn’t matter which one, so that Dorico does still need to restore the state of a VST instrument?

Hello
Thanks for the speedy reply - and the suggestion.
I tried this and I’m afraid it didn’t fix the issue. I also tried the following:

  • working with Rosetta mode toggled on or off before opening
  • blocking all the VST plugins, then restarting Dorico
  • unticking the box that says ‘open VST plugin windows on opening projects’ then restarting Dorico
  • removing a 2 min video that was attached to one of the flows (nothing high-res)

I wonder if it’s about the size of the file itself - which is odd as the only VST plugin I’m calling up (but not referencing in the score) is the one I’ve added, as an experiment, in line with the suggestion above.

I actually did another count up of the players and it was actually around 24 players (30 instruments) with 6 flows. So as an experiment, I made a copy of the file where I deleted lots to knock this down to just eight players, with just one flow. I also removed the video that was attached to just one of the flows. In this cut down file, the transport activates after 20 secs or so. So I think this cut down file is now working, although I haven’t tried it enough times to tell if it does so consistently. The original file still has the problem though - I have to coax to start. The working file is fine once I’ve coaxed the transport to work - by means I can’t quite fathom.

…it does feel as though a routine is waiting to complete but it’s not at all clear what that is. Could it really take that long just to open a score with a few flows, if you have lots of players, but just one VST?

Thanks

Sarah

…and just to confirm: The file is open and I can move my cursor to any note on the score and play it (i.e. hear it activate external midi). The issue is the transport.

But I think I’ve found a weird fix in the original file, if I open the file, go straight to Play, then click on VST and MIDI and make any change at all, e.g. add or remove a dummy extra VST instrument, when I click back to Write, I can activate the transport just a few secs later.

I also do not have a clue at this moment, but could you please do from Dorico’s menu Help > Create Diagnostics Report and post the corresponding zip file here? Maybe the log files give me a hint.
Thanks

It would be interesting to take a look at the project itself as well, if you don’t mind sharing it here. You could potentially delete all the music from the project except (say) the first few bars if you’re worried about sharing the content here. I imagine you’ll find you can still reproduce the issue even with a cut-down version of the project.

Thanks @dspreadury and @Ulf - will do tomorrow!

Will DM!

Have scrapped the old doc and made a fresh one - and the problem hasn’t returned. Thanks!