Transpose Chord Track

How do you transpose a chord track so that it correctly prints the transposed key on a score?

Create a Miditrack, select all chords and use the function chords to midi. Then open the score editor for your new midi event. Select all chords again and change the root note in the info line.

Or just select all the chords in the chord track and change their root note in the info line of the project window.



:question: :wink:

I can only change the root note if I select each individual chord, which makes it quite a bit of work.

I created the chords using the chords to MIDI function. However, I’m not sure what root note you’re referring to. There is a root key in the new MIDI track. However, changing that key does not seem to have an effect. If I select all of the chords in the score editor, I cannot change the pitch of the first note (which is the root note).

What version of Cubase are you using (signature hint :wink: )? There was a bug that would restrict the ability to change multiple chords at the same time (under certain conditions you could and under others you couldn’t). But that was fixed with version 7.5.1.

If you select one or more chords you will see the root key in the info line of your project window (maybe you have to activate the info line in your layout settings). Click on the root key and you’ll be able to change it.
Info_Line-Chords.PNG
Cubase 7.5.20 (German version)

I didn’t realize there was an update to 7.5 already. I downloaded and installed 7.5.2 and now I can change multiple chords at the same time. I also see that I can now use the MIDI transpose function in the score editor which in 7.5 was not working if there was a chord track in the project. Maybe 7.5.2 fixed some of the other unrelated issues I’ve been complaining about that were broken in 7.5. Thanks for your help.

Hi,

thanks - i am able to change Root Note to a “Higher” roots than my orignal but not to “Lower” e.g. : My Root Note is “A” - it allows my to change to “A#” and “B” but not G,F,E etc…

Please advise!

Yes that is one of the characteristics of the bug that was fixed in 7.5.1. Upgrade.

When I select all the chords then change the root note in the info line the chords don’t change. The scales change but not the chords. Also, I can select only some new root notes - selecting others makes no change to anything. I’m using 7.5.2.

How do I transpose the chord track?

Thanks,

rgames

@rgames, I’m not sure what advice to offer. Check out this thread
http://www.steinberg.net/forums/viewtopic.php?f=181&t=35482&hilit=+chord+above
towards the bottom of the 1st page Steve and I started to figure out the specific symptoms of the problem. Initially it seemed like sometimes it worked and sometimes it didn’t. In the end it was a very repeatable bug. You can see if your symptoms match the test cases we came up with.

Like I said, starting with 7.5.1 the issue seemed to have been fixed - none of us who had been discussing it saw it after that. Just speculating but perhaps it is related to which flavor of Cubase you are running. I’m running the full version and while it seems unlikely they’d fix it in one flavor and not the others, you never know. If you are selecting both chord and scale events at the same time, try selecting them separately and then transposing (i.e. select all the chords and transpose, then the scales and transpose). Also you might try re-installing 7.5.2 in case something went wrong there.

Let me know what you find.

OK - it appears to transpose the chords so long as I select ONLY the chords and not the scales - thanks for that suggestion. I cannot, however, get the scales to work correctly. I can only transpose to some of the root keys, others do nothing. When I select a new root note for some of the scales, even the “Root Key” indicator in the info line doesn’t change. It’s as though I didn’t select anything.

So I still have to go in and manually change every individual scale…

Thanks again,

rgames

I find it easiest to deselect the option to automatically generate scales. Then if I want a scale to change I just select the single chord that is at the change position and insert a new scale there using the drop-down menu. Or alternatively use the pencil tool to draw in a new scale event. I’ve never run into a case where I can’t change the (misnamed) root note of the scale in the info line. If you can give me a specific example of where you can’t change the scale, I’ll see if I can recreate the problem.

The reason I don’t like automatic scales is because if you use a chord that isn’t properly in the scale it will insert a new scale event when in reality the scale & tonal center hasn’t changed - you’ve just got a couple of accidentals that need to be used. Depending on what chords you use it can look like you are just jumping from one scale to another all over the place when musically you haven’t changed the tonal center at all.