Transpose from C won't work

Hello,

When I use the transpose function to change D major to E major, no problem. When I try to transpose C major to D major the key will not get transposed even if I have specified C major with SHIFT+K “C” in the start of the flow. What am I doing wrong?

Are you transposing the whole layout, or are you trying to transpose just a small selection of it?

I am trying to transpose one whole flow. In the transposition dialogue when the key is not set, or set to C major, the transpose key signatures checkbox is greyed out.

[edit] To be completely clear, the pitches do move but the key does not change.

I experience the same…

same here.

dorico 1.0.20
mac OS 10.11.6
doricoTransposeCtoD_noKeySig.jpg
incidentally, it seems a little odd that i can choose a different key from C in the ‘from’ part of the transpose dialog - it’s as if Dorico doesn’t ‘understand’ that the piece is in the key of C (a) to begin with. is this something that the user has to set (i.e. what i have shown here is a ‘default’ score)?

the above is answered. when i explicitly set the fragment to C then the ‘transpose key signatures’ box became available. still, the ‘from’ part of the transpose dialog doesn’t gray-out the non-relevant keys.
Screen Shot 2017-01-21 at 10.49.13 PM.png

Yes, I get the same. All works fine apart from starting from C (when the Transpose key signatures box is greyed out). Although I’ve found that if you transpose, say from D to C, you can then transpose successfully from C - the Transpose key signatures box becomes active again.

that’s not what i mean. when you start a new score the default key signature is apparently ‘C’. but, if you look at the “used in this flow” panel, you will see that it’s unpopulated… there is no defined key. if, then, you choose ‘C’ as a specific key and click in your music - there is no apparent change to the music BUT the “used in this flow” panel is now populated AND the transpose will work properly. if what you want is for this to work with the default key signature (which is undefined in a new score), i guess that’s another problem. it might also be the case, although i haven’t test this, that music imported as xml that is supposed to be in ‘C’ is also undefined until a specific key signature (like ‘C’) is chosen.

doesn’t work for me :confused:

This will be because you have an atonal key signature at the start, not C major. (By default, newly-created Dorico files use an atonal key signature, not C major, which is why this is confusing.) You can address this by selecting any note/rest on the first beat of the first bar, typing Ctrl+K then entering C followed by Return into the pop-up text field that appears.

This seems logical, but for some reason this did not work for me.

By all means attach the project here in which you’re having this problem, so we can tell why that might be.

No, I’m not confused by C major and open key. It simply doesn’t work. I’ll upload a file as soon as I’m back in the studio.

I think the issue here is whether or not you have any music selected before you invoke the Transpose dialog: if you have nothing selected, then Dorico will select the entire flow and transpose it, which will include the C major key signature at the start that you can’t see. If you select the music manually, then you’re not actually selecting the C major key signature, because there is nothing there for you to select, so when you then transpose the key signature is not included.

Daniel, this is probably the explanation. But, surely I will often want to transpose just a portion of a flow… for this purpose perhaps an otherwise invisble KS could get a signpost… ?

Well, the fact remains for me anyway - I cannot transpose from C major:

In a new document with solo piano, I enter some notes.
I set the key to C major via popover.
I select all, go to transpose dialog, and transpose on major second up.
Music moves, but the key does not change - I cannot even tick that checkbox.

If I now add a transposing instrument like alto saxophone and then select all and go to transpose, the checkbox will be tickable, and I can transpose to D major.

Also, if I have set the key to D major, I can transpose back to C and C will now be transposable after this little excursion.

If I am missing the obvious, please enlighten me. It should be possible to transpose from C without having to resort to workarounds.

Thanks
LAE

Don’t do the Select All step: make sure nothing is selected, then transpose the music.

Thanks Daniel. I tried it again. See attached animated GIF, not really what I expected! A bit of a surprise.

  1. Enter notes.
  2. Set key.
  3. Make sure nothing is selected.
  4. Transpose major second up.

If I set the key before entering the notes, it works.
transpose.gif

What’s happening here, somewhat unexpectedly, is that after you create the C major key signature, despite the fact that you can’t see it, it remains selected, so only the C major key signature is selected when you invoke the Transpose dialog, and hence only the key signature itself is transposed. If you type Ctrl+D (to deselect) before you invoke the dialog, you’ll get the result you expect.

Thanks. That’s bit strange, but problem solved.
I guess I unintentionally discovered a way to select the invisible key signature C major…

Anyone who has read this thread now knows how to proceed. But it would surely be better to make some change to Dorico so that a more intuitive approach will work for everyone.

David