Transpose is weird

I must be missing something here…

I have the same passage of music pasted into piccolo and flute parts. Of course piccolo part is now mostly unplayably low.

When I select the notes in the piccolo and try to transpose it all up an octave, it only transposes the playable notes. Is there a way to stop that behaviour, or just transpose all the notes on an instrument?


transpose settings


See flow 2 in attached.
tectonics2023 v1.dorico (980.2 KB)


I’m sorry, I don’t have my computer in front of me. How are you selecting the notes that are to be transposed, with the System Track?

You’re right, the transpose dialog window somehow ignores the red notes. Fortunately, there are other (and easier) ways to move selected notes up an octave:

  1. Use the interval popover: type shift-I, ‘t8’, return.
  2. Use the key command ctrl-alt-↑ (command-option-↑ on Mac)
    Those work always.
1 Like

Thanks Pjotr, that did the trick.

This is as described for me in 3.5; in 4.2 the dialog won’t transpose any of these notes.
(The keyboard shortcuts work fine.)

There is something very peculiar about this file, or the notes themselves. “Number of divisions: n/a” in the transpose dialog would seem to be a clue. If I select “Transpose by: Number of Divisions” at the top, the selectors offer no choices.

I tried copying the notes and pasting into a new file, exporting as midi and re-importing to a new file, changing their durations … always the same. Certain of the notes still wouldn’t transpose. Finally I tried recopying them from scratch in a new file, and then they transpose normally, though many of them began life way out of range of the instrument.

I assume this was an XML import. What is so strange about these notes, I wonder?

Those notes seem to have microtonal pitches - e.g. the very first one has a MIDI pitch of 63.5 which is halfway between Eb4 and E4. The project hasn’t been defined with a tonality system that uses quartertones, and the notes don’t have accidentals that make sense with quartertones either, so Dorico doesn’t know how to work out what transpositions are available for those notes.

1 Like

thanks @Mark_Johnson and @Richard_Lanyon, yes these are quartertone pitches imported via musicXML (from Max and Bach project score externals). I’m still getting my head around what Dorico expects, and setting the tonality.

I doubt it has anything to do with this particular file, or with microtonality. I tried it with a piccolo part in a random piece I’m working on atm. As soon as I move piccolo notes below the staff, the transpose dialog can’t handle them anymore. Didn’t try other instruments.
Edit: I realise my piece originated in XML as well, although it’s very unlikely it contained microtonality. I’ll try to replicate in a fresh file.

I certainly find that I can transpose out of range notes for any instrument with no problems in projects I’ve created for myself. I’d be interested in a counter-example.

1 Like

Turns out I didn’t replicate any issue at all. The dialog works as designed, also in my current XML-based project. The only thing is: if I set the transposition to Perfect Octave Up, nothing happens. It’s only after also explicitly entering a non-zero in Number of Octaves that it starts working. If I simply choose Perfect Octave Up, Dorico could set this number to 1 as a matter of course, just like when entering C5 as the destination pitch. So it’s more of a UI quirk, and nothing to do with the OP.
(And wouldn’t it be nice if the destination pitch was adjusted as well when the user chooses an interval in the LH side of the window? Never mind.)

1 Like

Thank you! I didn’t even know midi supported that. That explains everything.

Sorry, that was a bit misleading - I’m not sure that MIDI itself does support it, but internally Dorico uses a representation of pitch that is based on the same scale as MIDI and I was just reading off the value from the internal diagnostics. (You can see something similar by looking in the Dorico status bar when you have one of the microtonal notes selected.) In some situations Dorico will attempt to import MusicXML that specifies fractional pitches, if they happen to be fractions that we recognise, and that’s presumably what’s happened here. However, this will only work seamlessly if the accidentals, key signatures etc are all consistent with the pitches.

Got it, thank you. (That makes even more sense.)

So weird, I can’t replicate this now, but it does still happen in the attached file (from my first post). My steps for replication:

Do you mean click on the first bar in the Piccolo staff of the flow labeled “3. Flow 2”, or a different staff and/or different flow?

I find that if I select the contents of the Piccolo staff in “3. Flow 2” and transpose it up by an octave via the Transpose dialog, it works perfectly, both in Dorico 3.5 and in Dorico 4.2.

Thanks Daniel.

Watch what happens here. I select the entire bar, and transpose up an octave, some work but some don’t. Then I undo and try to transpose up a note that’s out of range, and the dialogue box doesn’t offer me any options. [edit, I strongly suspect I’m just doing something wrong here, not the programme, but I can’t see what that is…]

Right – sorry, I thought that was cleared up by Richard’s original reply in this thread:

Those specific notes can’t be transposed because they have microtonal pitches. This is the expected behaviour. (Though it’s difficult to tell that those notes have microtonal pitches – if you select just one of them, you’ll see that the status bar read-out says e.g. G(micro)4.)

ah yes, so it was, sorry I lost track.