Transposing a section from B major to Bflat major

I can’t work out what I should enter in the Transpose dialogue to achieve this and not get the part still notated in B major but down a semitone. I’ve already changed the key signature. Screenshot of the dialogue is attached.

What do you get if you use the calculator in the right side of the dialog?

Augmented unison–down.

Lafin - so obvious I didn’t think of it! Thank you very much.

Ok - just discovered an annoying associated problem. The figured bass renotated itself - Very strangely as well (screenshot attached). I tried deleting it and re-copying it from the original Bmajor version, which is still there earlier in the flow, but it still renotated itself.

Did you have the figured bass selected when you transposed the music? It very much appears that you did not!

I guess not, but I assumed that by selecting the whole section that I was also selecting the figured bass?

Just trying to figure out how to select the figured bass along with the rest of the score now. It doesn’t seem to happen. I can select the figured bass if I don’t select the rest of the score.

Have you tried the System Track?

That seems to work but I’ve got a problem now in that I’ve since entered a lot more notes and I don’t want to undo all that just now. Is there a way of selecting the figured bass and transposing just that. I’ve tried using the filter but selecting the System Track and going to Filter doesn’t allow me to choose just the figured bass. Nor does selecting the whole passage (which doesn’t select the figured bass in any case). I’ve selected a line of figured bass and tried transposing that but it’s just writing a whole load of other very complex figures. It seems that the only option now is to delete this section of figured bass.and re-enter it. Fortunately it’s not too long.

You should be able to select the figured bass by first selecting the whole passage with the system track, then use Edit > Filter > Figured Bass to select just the figured bass in that passage.

Ok that worked, but now I have a slightly different issue. I have two scores open with the same piece of music in. One has the figured bass I want and I’ve copied it using the system track > filter process. I copied it into the second score. I couldn’t see it in the new score, so I assumed that I was going to have to enter it all again by hand, but when I used the popover it was clear that it was there but not visible. I have figured bass signposts turned on in the View menu. What am I doing wrong?

Have you shown figured bass for at least one player in this layout?

1 Like

Aah - that explains it! Thank you very much.

1 Like

Sorry I need to re-open this thread. I have copied a whole section within the same flow. The figured bass didn’t come with it. I’ve tried all the things above, including checking the selected instruments in Layout Options, and nothing seems to work. I don’t know what I’m not doing!

What tool have you used to copy? Try with system track to make your selection, the other ways might not copy the figured bass track…