Transposing Selection Key-Signature Option Greyed Out

I select bars to transpose and want to include transposing the key-signature.

In ‘Write’ mode I go to ‘Write > Transpose’ but whatever I select, the “Transpose key signatures” is greyed out. I have tried searching without success.

What do I need to do to transpose notes, chord symbols and key-signature of a selection?

Thanks.

Is at least one key signature included in your selection? If not, that option won’t be available - try selecting using the system track, that selects everything including key signatures.

Thank you Lillie for your reply and suggestion. Unfortunately that did not have the desired effect.

I tried selecting using the system track as you suggested and the wanted bars were selected. When I tried transposing using ‘Write > Transpose’, the “Transpose key signatures” option was then available and not greyed out.

However, when I applied the transposition, the entire song transposed including the new key signature and not just the selected bars.

I retried and checked and double-checked that only the wanted bars were selected, none of the other bars in the song were selected just the wanted bars. Once again, when applying the transposition the same thing happened.

Clearly I must be missing something here.

After you highlighted the bars you wanted to select using the system track, make sure you actually click the button in the system track to select the music itself (so that everything shows as selected in orange, not only the system track itself). Then choose Write > Transpose.

Thank you for replying Daniel.

Yes, I did click that small box near the end of the system track so everything in just my selection turned orange whilst the rest of the score was as normal.

I just tried it again as follows:

  1. In the system track clicked on the first bar of my selection so that bar turned orange on the system track.
  2. Scrolled to the last bar of my selection and shift-clicked on that on the system track.
  3. My selection on the system track is now orange and the system track for the rest of the score is normal.
  4. I clicked the system-track small box on the last bar of my selection.
  5. The system track returned to its normal appearance and everything in my selection turned orange. The unselected rest of the score was normal.
  6. Went to: ‘Write > Transpose’. The "“Transpose key signatures” option is still greyed out.

I should add that there is no additional key-signature placed in the selection. I am transposing from the default key of G into A with the original key-signature at the start of the piece.

Should I have to repeat the key-signature at the start of the selection first?

Yes, unless there is an actual key signature item/object in the selection, you can’t transpose the key signature - I understand where you’re coming from, but Dorico can’t transpose something that isn’t included in the selection. If you want to end up showing a key signature of A at the start of this section anyway, input a G key signature at the start of the section, which will then be transposed to A along with the rest of the selection.

Thanks again Lillie, that did the job.

Wow. Well, Lillie’s suggestion worked but man, what a convoluted way to achieve this result. Dorico is so VERY GREAT at doing most things very musically, this was a surprise to me at how difficult it was to do. Thanks again, Lillie!