Transposition D flat major to B major?


I tried to use Write/Transpose a major 2nd down from D flat major and ended up with C flat major.
How can I transpose to B flat instead?

Thank you,


Sorry, I meant B major!

Have you tried the calculator on the right hand side of the Transpose dialog?

To go from Db to B, you have to use a Diminished 3rd. A major 2nd below Db is Cb. Just the rules of spelling. Try that and see if it works.

But from Db to B is NOT a 2nd, it’s a third. (The note names are three note names apart, not adjacent.) That’s where you went wrong. Leo’s fix will work of course, but in future look at the note names when determining an interval, not at the keyboard!

The transposition did exactly what you asked it to. It transposed by a major second. (You wanted a diminished third.)


PS, I see R Pearl beat me to it, but oh well.

Indeed, a third diminshed! My bad!

But, the Transpose dialog only gives me Major, Minor, Augmented and Diatonic for quality when I choose a Third for the interval.

However, I got it to work following “pianoleo”'s suggestion (I also had to check “respell to avoid double …”).
Interestingly, when I used “Calculate interval” to go from D flat to B the Quality & Interval on the left, automagically displayed Diminished & Third.
So, why is it that Diminished was missing originally? BTW, the Quality dropdown now showed Diminished, Minor & Diatonic.

Thank you all,


The left hand side of the Transpose dialog is in a somewhat counterintuitive order. Dorico won’t show you a Quality that isn’t possible, but the Direction defaults to Up, not Down. I suspect if you’d set the Interval to third and then the Direction to Up, the Quality dropdown would then have offered you what you wanted.

A diminished third up from Db major doesn’t bear thinking about…

Dorico can handle triple-flat accidentals. So what’s the problem with F double flat major? :wink:

You would have to create a custom key signature for it, but life isn’t always easy.

The design of the dialog could use some changes. I’ve found that you have to set the interval first, then go back UP to the Quality dropdown to select new options which weren’t present if you started with that box. It would make more sense to have the Interval selection ABOVE the Quality, since that’s the order one needs to consider (and enter your selections) to make an accurate transposition. JMHO

Indeed your suspicion turned out right.

Thank you,



I agree with you.