Tremolo is not played correctly

Tremolo is not played correctly. The repeatable notes are not evenly distributed in time and a small gap is created at the end.
In the attached example is a tremolo (with 3 strokes) with the mentioned gap, and a written tremolo as it should sound.

Brahms-Tanz-Nr-4–a-Moll– (901 KB)

In Play > Playback Options, on the Timing page, set ‘Minimum number of strokes for playback of unmeasured tremolo’ to 4.

There is a long standing bug/issue where the note length is applied to the total length of the tremolo.

So, like, a normal note is played back at something like 90% of notated duration, but with a tremolo that 90% is applied to the “total” length, rather than to each individual note within the tremolo.

Thank you Daniel, that helped in my case.