Trill line collision

I have a trill line on a tied note that continues on to a new system and I cannot adjust the length of the line to stop it from overlapping the subsequent note and trill line. See video here (I also tried adjusting the End Offset X in the Properties and it did the same that occurred in the video). Any way to fix this? I don’t see any anything in Engraving or Layout options. Thanks!
ezgif.com-video-to-gif-converter

You should make those adjustments in Write mode, not Engrave mode.

I tried that and it also does not fix the issue. If I adjust to the left, then the trill indication disappears from the tied quarter note.

Check out: Engraving Options > Ornaments > Trills > End position for trill extension line > Exclude duration of final notehead. See if that setting is suitable for the whole piece.

Hi @jrun, I have three suggestions:

One way I found to mitigate this in this particular context (since the other suggestions didn’t give the expected result, at least to me), is to use a Note Spacing Change. (1)

Another way is to not use the tr symbol for the subsequent staff , since it seems that it takes too much space in this particular case (2).

Or you can just move the complete symbol+ line to the left (with the Start offset X) (instead of trying to shorten the line, which would be the End offset) (3).

Thanks for these ideas. The note spacing thing can work, but in my case, it’s taking a much larger gap to achieve the desired result, and depending on where the “rest” is located, it won’t work. I’m just surprised that this causes a collision in the first place!

I think the reason for the collision is that the minimum number of ‘wiggles’ in a line is 3. I thought there was a setting for that but I didn’t find one.

But my example is like your screenshot, how can it need a “much larger gap”? Can you elaborate/share an example?

@jrun, can’t you just adjust that first trill endpoint with Engrave mode a little to the left? It seems to work for me, however I don’t have your specific file. If you need to get it less than 3 squiggles, then maybe try to displace the whole trill a little left. Perhaps you could upload part of your project here to see if there is some reason this isn’t working.

Screenshot 2024-05-10 at 10.45.50 AM

Here’s an example with rhythm closer to what you had showing really close spacing if desired:

Screenshot 2024-05-10 at 10.57.49 AM

Hi @musicmaven1 thank you for your contribution. But as you see on my post above these things have been already suggested :wink:

(you can recreate exactly the conditions as in the original post screenshot and experiment with that particular situation, with the two notes with trill on different hights)

Hi @Christian_R - I’m just surprised things can’t be tweaked to a desired outcome. I find Engrave mode allows pretty much any visual thing you want when it comes to the placement of items.

Yes (mostly), and as you see in example 3., this works (moving the symbol and line together on the left, as it seems you also experienced):


The limitation of not being able to shorten the line itself is (probably) because the minimum amount of wiggles is 3, as @Mark_Johnson points out.