Trill lines extension

…Dorico doesn´t show any trill lines? Did I miss something? I have “always show trill extension” activated in the engraving options…not showing. Even if I activate in the properties panel…not showing. A problem with the font maybe? I am using Leipzig atm.

Thanks for any ideas that might help me out here.

Can you upload an empty version of your project?

I think this is going to come down to Leipzig fonts not being SMuFL. At least not the ones I found by searching.

…but it´s the Leipzig font that´s inside Dorico´s own library. Should not be a problem, should it?

I have a Dorico project which contains trills, many of which have the trill lines showing. When I went into Library > Music Fonts… , and changed to Leipzig, all the trill lines disappeared.

Ok. I will try and change the font. Although I really like Leipzig…

In case the Dorico development team investigates this, I discovered the following oddity.

Even though the Leipzig font does contain (at least a few of) the trill symbols - the “normal” one, wiggleTrill, is Unicode U+EAA4 - no wiggles appear after the tr. When I went into Properties and “fiddled around” with the various attributes, I noticed that when “Show stop line” is enabled, the stop line appears immediately after the tr, rather than where the wiggly line would finish - maybe some sort of offset is not correct in Leipzig (I’m guessing). This probably means that there is insufficient room to show even one wiggle.

Arpeggiation lines are also affected - they do not show up when Leipzig is the Music font.

1 Like

Sometimes it’s tricky with those trill lines, huh? If you’re not seeing them even though the ‘always show trill extension’ is on, it might not be about the font. Try checking the playback settings or maybe the specific note range. Sometimes it’s just a small thing causing the hiccup!

…it does seem to be the font. I changed from Leipzig back to Bravura and…trill lines showed up. Maybe there´s a workaround? I´d love to use Leipzig but without the trill lines it´s worthless…

In Font Styles > Default Music Font, add Bravura as a Substitute. Dorico will then fall back to Bravura whenever a glyph is missing.

(In fact, Dorico should add this automatically when you change the Music Font, so I’m not sure why this isn’t already happening.)

It’s compliant, but not complete. Leipzig only has about 600 glyphs, compared to over 3,600 in Bravura!


Thanks for the idea! But unfortunately Bravura is my Substitute…still no trill lines under Leipzig. I will stick with Bravura then.

Because, as @StevenJones01 said, the symbol exists in the font, so Dorico won’t substitute it. There seems to be a problem that it cannot be correctly drawn.

1 Like