Trimming audio properly

I don’t seem to be able to trim audio properly, because even if I turn off the snapping, I still can’t move the begin marker with high enough resolution.

What am I doing wrong?

I need this functionality to be able to record stuff from other apps which are too stupid to sync to Cubasis and then fit it in properly.

Have you adjusted your “snap?” when snap is disabled, notes and events will snap to a grid as precise as a 1/192 note. Is that what your trying to accomplish?
Old post, maybe you’ve already fixed this problem.