triplet MIDI import bug

When I try to import a quantized MIDI file with 16th triplets, I get a second voice that is full of rests that mirrors the rhythm of the first voice. This is separate from problems people have importing triplets more generally - this is just a straight-up bug, I believe.

Check it out:
Screen Shot 2018-09-09 at 9.06.06 PM.png
Thanks for your help!

This should be something that should be fixed in our internal build. If you attach the midi file here (or just a representative sample) then I can try importing.

In the meantime I think if you untick the splitpoint checkbox during MIDI import then it should import without the second voice.

Sure, here it is. Seems like the forum software doesn’t want to let me to upload MIDI files so I renamed it as a PNG :smiley:

Unfortunately that doesn’t seem to have attached. Try zipping it first, or use a Dropbox link