Trouble with Time Warp Editor

Hi, First, sorry if my english is not good, it’s not my language

I got a trouble using the time warp edition, i think it’s just a setting that I ignore:

In a project where there is a wave and a midi files i want to set the exact tempo track, by using the time warp to fit the measure with the drum hits (because we can see it on the waveform) but it change the position of my midi notes on the midi track.
I want that when i use Time warp with audio it DO NOT move the note on the midi track.

How must I process?


Hi, I made a video to explain the problem:

Somebody got an idea?

You create a dynamic tempomap with the time warp tool in the arrange window.
So: is the audio drumloop set to musical mode?

You should rather set some hitpoints in the audio editor
using the threshold to get 'em all at once.

Then click on “Create warp-ankers from hitpoints”.
Now you are able to quantize the audio like Midi.
There is a little “*” next to the Q-setting.
Click on it and choose audio-warp for quantizing
and then quantize it.

Best regards.

Hi, thanks for your answer.

Whatever the audio is set to musical mode or not the problem persist.

I dont want to quantize audio to fit a regular tempo, i want my midi track fit the exact tempo of the audio without changing the position of the midi notes.

I want to freely use time warp; make the begin of a bar fit the right place on the waveform, but the midi note must stay at their original place, they must follow the bar and not the audio.


Okay. Then still use the hitpoints but choose
“Create groove preset”. The grid for the MidiNotes is now given by
the audio drum groove. Now quantize the Midi and that’s it.

Best regards.

You need to set the MIDI-Track to musical timebase and / or check the different warp modes…

… Yes it was simply that :blush:

When I tried the musical warp my tracks wasn’t and obviously i don’t tried the musical mode of the warp with the tracks set to musical mode too.

Now it works.

Thanks :wink:

Yeah. But still. Using the hitpoints is way faster. :wink:

Good night!