True Coreaudio Support?

I was misinformed when I purchased Cubase 6; I use a macbook pro 17 inch with a dual core i7 processor with 4 GB RAM. This should be enough for me, but alas it is not so. Cubase is highly unstable and is susceptible to numerous audio crashes and crackles. Little did I know that Cubase STILL does not truly support Coreaudio. It’s pretty obvious that since it must convert Coreaudio into ASIO, Cubase is having stability issues. On a stronger system such as a Mac Pro, you wouldn’t notice this as much as on a laptop, but I unfortunately happen to have the laptop. So… I have no clue what to do. It is not the case that I have extra money to spend on an extra DAW. The only semi-solution would be to purchase Vienna Ensemble Pro AND a slave device in order to feed AUs into Cubase. Yet again, this is too much. I wanted to buy Komplete 8 but if I’m having issues with the simple HALion Sonic SE plugin, then I’m in trouble. Indeed I love Cubase itself because of the interface, but performance is important. The best i can do is 8GB RAM, but RAM doesn’t seem to be the BIGGEST issue. I actually have a couple questions:

1> Is Steinberg planning on creating a native coreaudio system within Cubase?
(Of course not… it seems that one would be made by now if Steinberg wasn’t so concerned with keeping the so-called “perfect” base code.)

2> I’m using Mac OSX 10.6.6. Does upgrading to 10.6.8 improve performance at all? (Or does it worsen it?)

3> I’m still on Cubase 6.0.0 The performance issues are so troubling that I fear the inevitability of updating errors and glitches. They never seem to test updates well enough, and for all I know the latest update will WORSEN performance or break something.

I hope someone can assist me with all of this. I’ve posted at least two other topics and the conclusion I’ve reached in this post seems to be the most logical one; I was a FOOL for thinking that Cubase, which only uses VSTi and ASIO, is a stable and good program for MY system.

Any suggestions about what to do next?

Update! Have the same MacBook and have no issues.

In your signature it says Mac Pro… not macbook pro. How is it possible that i am having such terrible problems when you don’t have any? (Supposedly) I keep getting audio crashes and voice dropouts… lag/freezing. If it’s not the Apple OS then I really don’t know what to do. Cubase simply is running terribly on my machine…I heard somewhere that preferences can get easily corrupted and mess things up…I’m desperately searching for a way to fix this. I have a late 2010 macbook pro by the way, not the latest one with the quad core i7. I have the dual core 2.66 GHZ one. So what are you suggesting? Wait for version 6.05? Every single update brings complaints and MORE glitches. This is really difficult. One person telling me that he has no problems isn’t really convincing


I have 2 MacBook Pros and a MacPro. I don’t have any of the issues you describe on any of the machines. If you’re running a .0 release, I’d strongly recommend updating. And yes, delete your preferences to rule that one out.

It’s a little silly of me to ask but how do you delete them? I can’t find my pdf manual at the moment. What do I lose by deleting them? Would they mess up any of my songs that use vst expression? I haven’t really set any customized presets but I need to be sure. As for updating Cubase, anything could go wrong really. And yeah, the CPU sometimes spikes really high. I get 60% CPU on idle with a project loaded. It’s really really bad. This was from the first time that I opened it up. I actually had to install it twice because the first time it kept failing to do so… I have no clue if that has something to do with it. So you suggest updating to 6.0.4…I just am not sure what could happen. Steinberg isn’t very good at adding features and bugfixes without producing more errors and bugs. I guess I have no choice though. How do you delete the preferences then? No Google search turns up anything really.

There’s a detailed guide in the Steinberg knowledge base, I recommend you start there.


Found it! Thank you. What do I lose by removing these files though? Cubase will create new ones of course, but what do I lose besides presets and the like? Anything that could ruin my current projects?

The file and folder names give quite a good hint and if you really want to know what’s going on behind the scenes you can open the xml-files and take a look.
I can’t guarantee it but I don’t can’t think of anything that would render your old projects unusable.
After the default files have been restored you should try to move your old files back, one at at time to see if there’s anyone in particular which gives you problem. In that case, you should remove it again, let the default file be created and then redo the relevant settings from within Cubase.
If removing the files doesn’t fix your problem then you can of course move everything back again and continue troubleshooting with something else.


All right I removed (and saved the preferences somewhere else). Stability HAS improved. It might just be dumb luck though. Cubase is REALLY unstable. I still get random instrument dropouts depending on how long the song plays, etc. The audio crashes will probably return although I haven’t had any. Still I’ve only replaced the preferences about 10 minutes ago. What is causing the instrument dropout? My CPU doesn’t seem to be overloaded exactly. Cubase takes too much CPU though. I’ve also changed the polyphony to 200 voices in HALion Sonic SE. Polyphony doesn’t seem to do anything. Also, the slider for RAM/HDD use is all the way on the RAM side. I still have remaining RAM so that can’t be the problem OH WAIT ONLY 600 mb RAM LEFT?! AND IT’S DECREASING! Sheesh! This is quite unstable. 4 GB seriously isn’t enough?. Sigh what a mess. What now?

Are you running at a low buffer setting? Have you tried increasing it?

Just a quick google for coreaudio brought this up:

maybe why Cubase doesn’t support it.

The buffer setting doesn’t really change the issue I mentioned. I haven’t gotten sound crashes in the usual spots ever since I removed the preferences though…that’s good. (Unless of course it’s just luck.) Interesting that Apple would let such big coreaudio bugs go through. It’s a shame. I love Cubase as a program but it really hates my computer. Or vice versa. RAM SHOULD help it a little bit though from what I understand. I’m still getting random instrument drop outs…

I run Cubase 6 on a MBP with 4GB RAM. It’s a 2009 Core 2 Duo, 2.53 mHz.

I support the view that there is something else wrong in your setup. Cubase is extremely stable for me - I use it for recording live artists with up to 24 tracks at once (24bit, 44.1k)

What hardware are you using? A bad hardware driver will cause you all sorts of grief. No names, no pack drill, but RME drivers are first rate.

Edit to say, 4GB is enough for me, but it would rapidly cease to be enough if I loaded a lot of VSTi’s.

To everybody who didn’t follow his previous thread:

He’s using the Mac internal audio. I told him that this is the root of his problems, but he doesn’t believe.

Waste of time.

@synchronizer: To conclude on my previous arguments, you can easily see by the replies in this thread so far that it is very well possible to run Cubase 6 on a Macbook Pro to your satisfaction, especially on the MBP Core i7 dual core you have. As I wrote before, I have a Mac Mini Core 2 Duo 2.26 GHz which is way inferior than your Macbook Pro performance wise, yet everything works very very well here (40+ audio tracks, Virus TI, Toontrack Superior 2.0, Izotope Alloy on almost every track, 5-6 Reverence instances, Izotope Ozone 4, plus guitar over VST Amp Rack in real time). Oh wait, there is one difference: I have an RME Fireface 800, while you are using internal audio …

I have the newer macbook pro (2011) Bought in july 2011.

I am coming from Windows (95-98-XP-7).

My findings: Windows is “more efficient” (for cubase) when configured well. Lower ASIO readings in general.

This goes for internal sound card as with Toneport UX2 and UX8.

I CAN run cubase at low latencies (lower then on windows, 32 buffer size. On windows this is simply not possible). But this will only go well if I don’t have too many effects/ soft synths. Especially Addictive drums makes Cubase ASIO go nuts (spikes)…1 instance of Kontakt 5 (several instruments) + quite some audio tracks is ok…

I imagine that with a good (firewire) audio interface things will be a lot better (more Windows- like).

With the UX2, my acer I3 laptop, 3 gig ram beats the mac by a large margin. Again with an RME things should be very different.


LISTEN: AUDIO INTERFACES do not do ANYTHING. I tested it on a very expensive MOTU firewire device. There is absolutely no change. I have a 5400 rpm drive but I doubt that’s the root of the problem. I find it very disrespectful that you think that I’m a waste of time. The interface didn’t do ANYTHING. Maybe I’ll get one down the road but I don’t think it’s the problem. I’ll see if I get anymore crashes.

In my experience an audio interface with good drivers may solve certain problems. Especially regarding stability (at low latencies). Maybe in your case the solution problem lies elsewhere.


P.S. Maybe there is something wrong with your mac (hardware)…

I’m starting to think it’s my mac too. I notice other audio issues outside of Cubase. Sometimes I get audio crashes for less than a second while playing simple mp3s on the computer. Even Garageband seems to use a lot of CPU. 60% I believe sometimes on tiny projects. I don’t even use Garageband so a tiny project is about two tracks… Yes something fishy is going on. Also I just had a random crash with Cubase. I hope it’s not my hardware because then from my understanding I wouldn’t be able to get a replacement. Also, my concern isn’t latency per se… It’s random instruments deciding to not play their notes, random crashes, and slowdown. Sometimes Cubase freezes for a few seconds after pressing play or stopping a recording. Sometimes when simply dragging MIDI notes!

Still, deleting preferences seems to have solved the audio DROPOUT issue… for now. i may e simply lucky. I still have random instrument dropouts though. For example I have a few tracks altered over each other with violins, brass, piano, etc, and sometimes the brass notes cut off too early to the violins don’t play their part. I don’t even think the CPU is being overpowered…

I’m inclined to agree that it’s not that you’re running on the internal audio. In fact if anyone suspects that their audio driver is causing problems, the best way to test is to switch to the internal.

OK. Have you re-installed Cubase, dumped preferences, removed any user templates, and removed any third party plug-ins?

Those would be the next steps I would try.

If that fixes the crashes, reinstall plugs one by one to find the culprit.

Just read your post above. The problem is clearly not Cubase. Suggest you get specialist advice about your Mac… if it’s under 12 months old, you would be covered by the makers Warranty.