Trying NotePerformer - still no sound (or VSTs)

Hi folks -

First, I have searched the forum (and the Google) as thoroughly as I can, and I’m not finding the answer.

After reading so many great things about NotePerformer, I thought I’d give it a try. I installed the NP3 demo. I’m running Dorico Pro 2.1.10 on a newer Macbook Pro.

It appears to install, and “NotePerformer” is an option in Preferences and setting the Playback Template.

When I try to play the project (an orchestral score), there’s no audio.

In the Play window, there are three blank VSTs (see screenshot). When I click the little cog next to one of the instances, the expression maps are assigned to NotePerformer.

I have tried uninstalling and reinstalling NP, restarted the computer, and run around the table three or four times sprinkling salt on the cat.

It’s almost like NP is installed (and loaded), but not the sounds.

I hope this isn’t restarting an overdone thread! Thanks for any help!


Have you tried resetting your sample rate in Preferences? That did it for me the first time I got NP.


what happens, if you in Play Mode in the ‘Play’ menu go to ‘Playback Template…’ and choose your NotePerformer? At least it should show up in the right panel under VST Instruments.

That’s the same as what he tried, above.

Thanks, Dan -

I’m using the built-in output, 44100. I set the sample rate (in preferences) to 48000, no luck. I set it back to 44100, also no good. (Each time, just in case, I switched the playback template back to HSSE and back to NP, in case something needed to be reinitialized.)

Additional info: see this attachment when I see available VSTs. NP isn’t there (right?).

Jim, it looks as if you might have to reinstall NotePerformer - as it doesn’t show up here (I know, you already did, as you said in your first post).
When I tried NP a while ago there was a validation/registration process happening (some visible window) after opening Dorico and before one could work on an project window. This did not happen reliably always, but without this validation progress NP would not work. May be you could investigate into that direction.

Jim, if NP does not appear in that list, then it is not recognized by Dorico and no wonder that there is no sound. In that case - as already suggested by K_B - you need to check the NP installation.
If you still can’t get it going, please choose from Dorico’s menu Help > Create Diagnostic Report. That will create a zip file on your desktop; please send it to ‘u dot stoermer at steinberg dot de’.

Well, I’ve uninstalled and reinstalled NP several times. Sometimes restarting or logging out in-between. Even re-downloaded the installer.

I never got a validation window when opening for the first time. Weird.

Ulf, I’ll send you a report. Thank you!


It could be that for some reason the audio engine hasn’t picked up the presence of NotePerformer. You can force it to search for the plugins again by deleting the folder:


I’m already in direct contact with Jim and also proposed that.

OK, I have no idea why, but now it’s working.

It was some combination of deleting the VSTAudioEngine2 folder, restarting Dorico, and restarting the computer, but now it works. Wish I had more info for anybody else who encounters this.

Thanks to Ulf and Paul for your responsiveness - I’m impressed!


I’m very glad to hear that you got it working. I suspect it was just a case of the audio engine needing to rebuild its VST plugin database.

I’m having a similar problem with NotePerformer. I recently replaced my old computer, so I had to reinstall everything. NotePerformer worked just fine on my old computer. After reinstalling, it worked for about a week. Now, it pops up the NotePerformer window, which immediately disappears. And no sound at all. I’ve tried deleting the VSTAudioEngine2 folder (although it’s VSTAudioEngine2_64 on my machine), and also reinstalling NotePerformer, but still nothing. This is on a PC with Windows 10. Any help is greatly appreciated. Thanks!

Please start a new project with a single instrument, add a couple of notes, make sure the NotePerformer playback template is applied (via Play > Playback Template), then save the project, zip it up, and attach it here. If you could also quit and restart Dorico, then do Help > Create Diagnostic Report and attach that resulting zip file as well, we should be able to figure out what’s going wrong.

Here are the files.
Dorico (346 KB) (311 KB)

It looks like you don’t have the right playback template chosen, and instead you just have ‘HSSE+HSO (Pro)’ chosen: can you make sure you do Play > Playback Template and choose ‘NotePerformer’ from the dialog, then try playing back again?

This is what I see when I go to Play>Playback Template. It also shows NotePerform on Edit>Preferences, and shows NotePerformer64 under the VST Instruments in Play. I’ve attached the test file again, just in case. Thanks! (411 KB)

Yes, choose that “NotePerformer” item and OK, then try playback again. It shall work.

That worked. It took me two tries of shutting down and then restarting to get it to work on an existing project, but it eventually did. Thanks very much for your help! You guys are the greatest!