Trying to make Ensoniq SQR+ patchnames work

I have a SQR+ patchnames doc (txt) that worked fine in C4.5, but does not in C12 (Mac Intel). I have compared it to the patchname file for Ensoniq ESQ, to try to find out why. I created a SQR+ file adapted from ESQ, spaced out properly, with the same header and tail. Steinberg support can’t figure it out, either. I put it in the same “inactive” folder – Studio>as the ESQ (Roland, Yamaha, etc.) list, but More Options>MIDI Device manager>(Select Device in left column)>Install Device, but the SQR list does not appear there. But the ESQ, Roland, etc lists that are in the “inactive” folder, do…Anyone want to take a swing at it? I’ll send you the list…Much Thanks

PS - I have a Yamaha Motif ES and it’s patchnames list works fine. I read in tgw manual that the script should end with

So, tacked on to the existing script --

[p1, 0, -1, -1]
[p1, 0, -1, -1]

Also it doesn’t work with simply ending the patchnames list with

I also put it in the patchnames (not the “inactive” subfolder) folder, and it still won’t show up…


Maybe I haven’t got the issue at its full dimension, but FWIW, I have three different external instruments such as the SQR+ and the corresponding patchnames for each of them are stored in three different .xml files, not .txt ones.

I created them with the Define new… option (or the equivalent, as I have created them a long time ago, probably as you, circa the C4.x days) in the Add MIDI device window and set the patchnames list one program after the other, before saving them. A tedious process, but once done, I never had to come back at it, unless changes occured in some patches stored in the synths.

Beside this, what is the “inactive” folder ? Here, I have them in a dedicated folder which contains both my projects subfolders and other files which aren’t supposed to be automatically updated when working with Cubase, the <ExternalInstrument>.xml ones being among them. Cubase recognize them each and every time they are needed, doing so.

Thanks - I was beginning to think I was the outlier here…
Both 4.5 and 12 have inactive subfolders. A long list of MIDI gear patchnames in there…
The other patchname scripts, including the ones that come native in Cubase, are all txt. I can try converting to xml and see if it works.
Could you send me your SQR+ patchname script?

OK, I see what you mean, now or, more precisely, I guess that you are talking about the ones included here (on a Windows based system) :

C:\Users\<username>\AppData\Roaming\Steinberg\Cubase 12_64\Scripts\Patchnames\inactive

Honestly, I never tried to deal with these .txt devices definitions files, because the patches that I use are completely different than the original factory ones, for each of my instruments. And I can’t provide you a SQR+ patchname script, as I am not using one, but three other synth modules.

Actually, I rebuilt the patchnames list for each of them, directly in the Patch Banks panel of the Open Device > [Device name] window and save/retrieve them as needed using the Import Setup / Export Setup buttons and these deal only with .xml files.

This said, and from what I see, and despite what you are experiencing, a given patchname script can be made available if you bring (or rather copy) the involved .txt file from the ...\Patchnames\inactive folder to the parent ...\Patchnames one.
This is easily checkable : in the copy of the .txt file made, edit the [device name] variable in it. The edit will appear as so as a device label in the MIDI Device Manager > Install Device list.

EDIT : precisions added…

Much thanks for staying with me :-). This doesn’t make sense at all… I took a script for ESQ1, which is in the inactive folder, dumped the patchnames, modded the header to SRQ+, dropped in the SRQ+ patchname list, duplicated the format and it still would not see the SQR+ list… I even went through the other patchname txt lists to see if I could find what I am leaving out… Grr…
I moved a copy of the list out of inactive, into the patchnames folder and still nogo. Actually, I think Cubase moves the scripts out of inactive, when they are called up. But neither way worked.
on Ventura OS the path is Apps>Cubase12>Contents>scripts>patchnames>inactive.And Just >patchnames, for an attempt to get it to work that way… .
With the SRQ patchname script in either location the “Add midi device” list, it still doesn’t appear.
Maybe convert a txt to xml?

Here is a pdf of it (The board won’t let my upload txt)
Ensoniq SQR+.pdf (29.1 KB)

I’m not a Mac user, so it would be difficult for me to confirm the path used on it.

This said, I looked at your .pdf file and compared it to the SQR+ specifications that I could gather and the ensoniq esq-1.txt bundled with Cubase. I see several differences that could be related to the fact that the SQR+ is more recent, but still… Apparently, the whole patches list of the latter is divided in groups of 40 patches with the following separators :

[mode] Programs 1
[g1] group 1

[g1] group 2

[mode] programs 2
[g1] group 1

[g1] group 2

… and so on. So, I have made a new ensoniq sqr+.txt file from both the ensoniq esq1.txt one and your patches list, following this model and being sure to save it in the parent ...\Patchnames folder . The file basically works, using first the Install Device option, then the Open Device one. I’ve been able to install the ‘fake’ SQR+ as an instrument rack :

BUT… I haven’t succeeded to make appear the patches which are in the [program 2] section (which, I guess, are the ones stored in the 80 RAM memory bank of the SQR+). I probably made a mistake, fiddling with the LSB/MSB bank numbers (maybe you’ll have to change them for , 0, 0] and , 0, 1], I don’t know). Anyway, I’m almost sure that there is a combination that will make them appear in the Programs list of the inspector, as the 100 first ones, but you’ll probably have to look more closely at what is indicated in the script documentation.txt file.

FWIW, here is the file (in .zip format, as indeed, no .txt file can be uploaded on the forum) :
ensoniq (1.9 KB)

Much appreciated - at least you got it to work. As soon as I get this song project done today, I’ll give it a try on my Mac, and see if it works with my SQR+

So I put in the patchnames folder, in that same path, restarted and C12 still doesn’t see it…
I wonder if C12 is even looking inside that patchnames folder. I found the patchnames folders for my old Cubase, in application assistant. I’m going to call Steinberg tomorrow and verify the patchnames folder location. Something is fishy here…
Much thanks

Sorry to see that it doesn’t work for you. And yes, keep us informed about any Steinberg answer to the issue, as I’m out of idea, at this point, but would like to know what could be misbehaving, on your end… :neutral_face:

I would like to know what the heck is off, too…

Steinberg now think the prefs are off. But I can’t think of how the patchnames folder location got misdirected…

from ST:

I can confirm you do have the correct file path for the patch scripts. You could try resetting the program preferences again to see if that forces a rescan of that folder (it should):
From your desktop, select Go>Library (Hold option to reveal hidden library folder)>Preferences>Cubase 12. Drag this folder and any previous Cubase folders to the desktop. This will reset your preferences to their default settings next time you open Cubase. Test again to see if the patch script shows up.

When I open that see I have prefs from 5 (!) versions of cubase: SX, 4, LE5 (I have no idea how that got there), 7, and 12.

Wait a second - THIS script location does not contain the one that shows up under package contents…
AHA! That did it! This path: Application> C12 (show package contents) > Scripts> patchnames> Inactive is wrong.

The one that Midi Device manager > Devices >Install devices sees,
Users> (My Name)> Library. Peferencs> Cubase 12> Scripts> Patchnames> Inactive.

Putting the patchname script there works…

A big fat “Duh”

As i’m using a PC, it’s difficult to say anything paths related. But, at least, you got an answer. Will look at this more closely in few hours (sleeping time, here… :smile:). And yes, it’s a mess… :expressionless: