Trying to move event Snap Point but button 'Show Audio Event' is missing in C12

I want to use the snap point for usual reason of placing an event based in line with the peak of the wave but when I double click the event to open it in the edit window below the project window, there is no snap point ‘S’ showing. So I searched the net and found Greg Ondo’s excellent video re same:

but at time 5:02 he says (just like the Steinberg manual) to click on the ‘Show Audio Event’ button but that button doesn’t appear in C12 in the edit window or project window that I can see anywhere.

Can anyone help me find it (or the updated method for C12) please?


Do you have Audio Event selected? Isn’t it Audio Part? Could you attach a screenshot, please?

Hi Martin,
Thanks for your response.
Yes I it’s an audio event. I double clicked on it as usual to open it in the edit window as per screenshot:

This is happening with all events, there is no ‘S’ (for snappoint) appearing in the edit window.

Please set the Editor Display Mode (eye icon) as per the screenshot:

Hi Johnny,
Many thanks for your reply. I just ried that but no luck :frowning:
I already had the eye set to ‘Show clips & events’ so I guess even that should have worked but I tried just ‘show events’ as you suggested but there’s still no ‘s’ symbol on the wave file in the edit window.
This isn’t event or project specific either, it doesn’t show in any of my projects :frowning:
There’s probably 1 button somewhere that needs pressing but I can’t find it having tried all the edit window buttons and some at the top of the project window.

On your screenshot the option to show events was not activated.
I cannot find any other setting that would hide the snap point indicator.

Where are you looking please? Is it only the dropdown menu or is there another indicator of ‘show events activated’?

I just tried C11 and it works fine in there so I guess it’s setting/button somewhere in C12.

Yep, there is only this dropdown menu and, unless the Show clips option is activated, you should see the snap point marker. Here, I have it, no matter if I use mono/stereo events or rendered ones.

Have you tried to restart Cubase in safe mode, deactivating the preferences ? Just in case… :neutral_face:

Thanks @cubic13 !!
That of course has worked! I startup C12 in safe mode and back comes the ‘s’ snap point like magic!
So this deleting preferences to solve issues seems to be a common thing, a so called solution! rather than calling it what it really is, a string of bugs that should be sorted. I know it’s a complex program with many amazing features.

Therefore, since this is what we have to live with, I tried to find on the forum (but failed), a guide to recovering earlier preferences files, which is presumably the quickest way to try to restore our workflow rather than starting with Cubase default and adding all our prefs from scratch which have taken many years to fine tune.

UPDATE: I do save my preferences & profile once a month, so just now I opened Edit, Preferences and selected a much earlier set of preferences & clicked on ‘APPLY’, then double-clicked on the event but the ‘S’ snap point event still didn’t appear. I tried the same but clicking on ‘default’ and that didn’t work either. I then restarted Cubase hoping that would activate my preference selection from this session before closing it, but no.
I guess there is a system level to solve this i.e. copy/paste the required preferences backup file into the current folder or if there is only one folder, find one of my many PC backups and copy the file from there to the active folder?
If this is the case, I need to find the folder (only found a Cubase 11 user stating:
C:\Users\howlingulf\AppData\Roaming\Microsoft\Windows\Start Menu\cubase\Cubase 11_64
which must be different to C12 as that folder is not on my PC)

Also, what is the point of the 'Edit, Preferences ‘save’ button if one can’t restore any saved preferences?

Can someone please point me to any guide for this or advise the best way?

FURTHER UPDATE: On holding down Ctrl+Alt+Shift on startup to once again access the selection screen to go with default preferences, Cubase has now lost my licences and says 'no lince found, Cubase will now quit!!!) This has happened before and I know the next hour will be wasted trying to get Cubase back running FFS! The time that would have saved having a prefereed snap point has been well lost!

Thanks in advance :pray:

As you are using, as me, a Windows setup :

  • Go to the C:\Users\[UserName]\AppData\Roaming\Steinberg\Cubase 12_64 folder (I even made a shortcut on Windows desk to accelerate the process),
  • use ctrl + A to select all its content, then ctrl + C to copy,
  • Go to another safe location (in my case, and after eventually having create it) : D:\Cubase_prefSaves\C12050_[YYMMDD] folder
  • use ctrl + V to paste the whole content saved in it.

I do this on a regular basis, and especially when I change something in either the Preferences or the Studio Setup configuration. This way, no matter what could happen, I know I can retrieve a whole recent Cubase configuration set, simply by copying back the settings in the first location, in case something went wrong with Cubase : it takes just half a minute. So, sure, there is now the Edit > profile Manager feature, but well… Let’s say I’m used to the more basic, brutal and efficient way of doing, this, since countless years. This way, I always have retrieved my configuration settings after eventual and seldom Cubase crashes or misbehaviors…

Thanks a lot @cubic13 !!
Once I get Cubase licence restored (previously fix of uninstalling & reonstalling Steinberg Activation Manager’ didn’t work) I will restore those files you mention, from my latest backup & try those, then if still no ‘s’ snap point I’ll do the same from an earlier backup etc.

Try to run again, as administrator, the Steinberg Activation Manager, after eventually having update it, if required : you should be able to check and eventually retrieve a full working licence from it…

Thanks again @cubic13
That got me a bit further …

So now I’ll reboot and try again …

I use a similiar, just slightly different technique. I go to the parent folder <C:\Users[UserName]\AppData\Roaming\Steinberg> and create a .zip archive of the preferences folder (right click, Send To → ZIP compressed folder).

Also the last time I had a problem with corrupted preferences I took my time to figure out which file exactly is rotten. This way I lose ‘only’ a few of my settings. However, this requires at least some knowledge about the files that are stored there or stamina when using the trial and error technique.

System reboot is usually the thing to do when recceiving “no license” messages.
It seems that part of the copy protection system likes to stop functioning.

Yep, it’s more or less the same thing. But life is short, and even if I more or less know which are the files involved (most of the time, it’s the Defaults.xml one), I copy and paste the whole folders and files set, to avoid any added hassle… :slightly_smiling_face:

Yep, that did the trick! I now have Cubase at least working to continue trying with the restore backup of prefs. I will save current ones away first as you suggest. :pray:

UPDATE: I went back to Feb backup, then Jan then even July 2022 butnone brought the ‘s’ snap point back as deleteing the preferences file does.
So I’ve decided to live without the ‘s’ for now until I really need it then delte preferences then.

Thanks for all you help though peeps! Especially Cubic & Johnny for your real-time assistance ! :pray:

I’ll now tick this thread as ‘solution found’ being the usual ‘DELETE THE PREFERENCES ON STARTUP’ preferably having a backup from a time before the issue.