Two flows on one page

Hello Dorico users, I’m trying to get two flows and their respective titles on to one page. I’ve been to Dorico help “Allowing Multiple Flows” and I’ve trawled thru Daniel’s tutorial on Preces and Responses. But I’m not getting there. The second flow is Tacet, and there should be plenty of room for it. I can even get the Flow 2 Tacet text to move, but it leaves the Flow 2 heading behind.
Any ideas how I can move the whole of Flow 2 (inc. heading) on to page 1. Here’s a pic…

Your flows should all be in the same frame. You’d need to expand that frame to fill the page. Or draw a new MA music frame at the bottom of the page, and set Flow 2 to populate it.

First, remove the page overrides (rightclick the page icons upper right) …
[edit] then, if necessary, set new flows to allow starting on existing pages (layout options/page setup/flows…at the top)

Thanks to you both. When I remove the page overrides, then Flow 2 jumps on to p.1. But my project title disappears on p.1. Why is that?

…and if I change the current set to Default Full score, then remove page overrides, I keep the project title, but lose the instrument name at top left.

Hmmm… the settings are separate for score and parts… check that first…

As F says, your part and full score master pages are different.

If you want to make layout changes, make them to the master page, not the score itself! https://www.scoringnotes.com/tips/working-with-master-pages-in-dorico-part-1/

Thanks to Fratveno and Dan. Dan’s web tips are very useful. Another question, pls.
When I use the Default Full Score Master, everything is perfect. But this is a tpt part, so I feel I should be using Default Part Master. But when I do, the Project Title and copyright line disappear. Any ideas?

You need to double-click on the part master page to edit it, and add those text frames as desired (using tokens). Then apply and close, and make sure overrides are removed. Those text items will be added to the layout page.

Dear Dan, Thanks. Well I’ve reverted to the Part Master. When I look at it, it has tokens for Layout Name, Project Title, and Copyright (but not the Flow Title, strangely enough). Here’s a pic.


But when I open the part, only the Flow Title shows, and nothing else. Pic…

Any ideas?

Well, the flow title is showing up because you have flow headers set to display. Layout Options–Page Setup–Flows.

I’m not sure about the other bit. Perhaps you have no values entered for those fields?

Yes, I do have values entered for these fields (Layout Name, Project Title, and Copyright), but they’re still not showing. I’ve now noticed that when I click on the p.1 icon at the RH side of Engrave Mode, then it’s not the First Default Part that illuminates, but the Default Default Part. I imagine that may be significant.


Any ideas anyone?

Check your Layout Options for the part layouts. My guess is that they’re using Flow Headers throughout, including page 1, and so the First Master Page isn’t coming into it at all.

Yep, you need to assign the First master page to page 1.

Leo - I didn’t know that flow headers changed the way that pages were assigned master pages… do they?

On occasion I’ve had to manually assign a master page change to a particular page. You can right-click on the page in the top right panel and force it to use the First master page.

Dan, take a look at Layout Options. There are options for where the First master page should be used.

Also make sure that the Parts Master Pages are using the tokens that correspond to the place(s) on the File Info pages where you have entered the Title, Copyright, etc.

Thanks to you all for your helpful advice. But I got it in the end. In Layout > Page Setup > Master Page, it was set to Default Part, and the selection button at the bottom L of the page was set to Full score. I changed the first setting to Default Full Score and everything on my page displayed perfectly.
Frankly I don’t know why everything had to be set to Full Score for the Part to display properly. In fact, I don’t find Dorico master pages at all user friendly.
Btw, can someone explain what it means when the page icon in top right has a green border, as in this pic.


I’m guessing it means the First page is selected…?

It means you have a master page change set for that page, and all pages after it.

I believe that this drop down selection is used so that you can set the type of Layout used for a particular Master Page set, in essence a 2nd way of making choices as opposed to doing this in Engrave Mode on the right side of the screen. I’ll agree that the terminology can get a little confusing and it takes time to wrap your head around all of this conceptually.

Actually, everything isn’t rosy just yet. I’ve just noticed that all the parts lack the instrumental part name in the top left corner. Which is to say, by changing to Full Score, as noted in my previous post, I made all the parts display as Full Score (without the instrument part name). But the Default Part Layout is just as corrupted as before. Does anyone have any ideas? I’ve attached a copy of the score, having stripped it down and set playback to silence. (Why do Dorico files have to be so huge?) The issue is that I cannot see (a) Project Title (b) Flow Title © instrument name (d) copyright line, in the Parts.
By the way, Dan, what is a “Master page change set”?
Project Test.zip (649 KB)