Two issues with Dorico

I’ve come across two issues that don’t seem to have a resolution as of this date.

  1. there isn’t enough space after a 2 note tremolo (that’s two notes with the tremolo has marks between them) if there is an accidental on the 2nd note. The tremolo hash mark collides with the accidental.

  2. I suspect this second issue is just one that not many people have need for, but it IS in the program: making dashed ties on multiple notes in a row (I have 10 bars of tremolo whole notes), only the very first tie shows as being dashed, while the other ties just appear as “solid” regardless of the setting.

NOTE:
On a completely unrelated note: I’ve been a Finale user for nigh on 30 years (whenever the first version for Windows was released), and I have to say I approached Dorico with some trepidation, since the basic principles were radically different from Finale’s approach.

I’ve been testing it out for a few weeks now, and am starting to get much more comfortable with Dorico. I would like to congratulate you on the actual ease of note/data entry with the program.
*I was able to enter the entirety of my violin concerto in about a week (taking into consideration my lack of actual speed due to a beginner’s unfamiliarity with Dorico). This week permitted me to enter all the notes, dynamics, phrasings, articulations, volumes, etc… *
With Finale it took me over a month to enter the whole piece. And this did not include the parts, which took several months afterwards.

With Dorico, the parts are already done (with a bit of minor tweaking for page turns and for cues).
I have to say that I’ve found Dorico a joy to work with, and am looking forward to the remaining bugs and issues being resolved, hopefully in a not too distant future.

5 Likes
  1. That sure seems like a bug (or at the very least, unexpected). To work around it, switch to Engrave mode. There you can select multiple ties in the chain using Ctrl- or Cmd-click.

EDIT: I see Vili has already answered here. If you cross-post, please include the FB link.

1 Like

I will try to remember this cross-link thing. I’m not all that well-versed in forum tricks of the trade, and will definitely forget to do things that are normally expected of forum users.
but I will do my best.

It’s not a big deal. Glad you got some solutions.

The tie issue is, I suspect, replated to one of my long-term annoyances:

When you create a trill over multiple notes, like, say, a multi-bar timpani roll, with a specified interval, the interval is only applied to the first note, and you have to into engrave mode to fix all the other notes.

Why this behavior exists, when it’s clearly IGNORING user intent, baffles me.

Can you give an example? I haven’t found a case where this is a problem. Normally the stems keep the tremolo beams away from the noteheads. I tried it with semibreves (no stems), but even if you prefer the beams right between the noteheads (not the default setting), the note spacing is wider for those.

sure. here it is before I applied a simple fix (that sadly won’t work for all situations).

How did you fix it? In this case, I would switch to manual note spacing, click on the square handle above the second note, then click on the circular handle below it, and use Alt-right to nudge it.

I can’t think of a scenario in which that wouldn’t work!

Hi @Michel_Edward ,

I tried recreating what was in your screenshot, and the tremolos didn’t collide with the second note accidental. I’m using Dorico Pro 3.5.

Here’s a file with what I got (I added two bars at the end to see if this changed the spacing but it didn’t): Two issues with Dorico.dorico (427.0 KB)

I also made 10 bars of tied tremolo whole notes. As @dankreider said it was easy enough in engrave mode to Command + Click all of them and change them to dashed lines. I might just be tempted to use one slur over the whole lot and hope the player gets what you’re wanting (see viola part), but I’m sure you know better than I do how it should be notated.

Hope this helps.

I fixed it by adjusting the padding of the tremolo hashes.

Once the notes are all tied together, a possibly quicker way of selecting all the ties is to click any note in that tie chain while still in Write mode. This will select all of them. Then go into Engrave mode to set the Dashed property for all the ties, which will happen with just the one click.

1 Like

yes, you didn’t get a collision because you didn’t place the tremolo hashes where I do. on whole notes they go between the two notes.

Hi @stevenjones01 ,

I tried that, and although it did select all the ties in the chain, when I used the properties box to change them to dashed it only affected the first one. Worth trying, but what Dan said about Cmd clicking multiple ties is the way to do it.

Were you in Engrave mode when you did Properties > Ties > Style > Dashed?
I have discovered that, after tying the notes and selecting them in Write mode, going into Engrave mode has the effect of de-selecting any ties and notes on systems following the one on which the tie chain starts - it didn’t matter whether there was a System Break in place or if it was just Dorico spacing things out automatically. However, when I clicked on Style > Dashed, all of the ties which were still selected became dashed.

Hi @stevenjones01 ,

I entered some standard tied notes, and you’re absolutely correct about how to change the tie chain. Thanks for that. I think it’s because I was trying to write something non-standard. In the file I’d attached I had a tremolo between two pitches in each bar and tied the first pitch to the first note in each successive bar. Don’t think it should be notated this way, so no wonder Dorico doesn’t like something that’s notated in a strange way.

The issue with changing the style of multiple ties in a tie chain in Write mode is certainly an annoyance – there’s a boring technical reason for it, but in the end nobody (quite rightly!) cares about that. It’s something that we do intend to address in future, though it’s not something that’s super simple to address (the boring technical details are not insignificant in this case). The advice to make this adjustment in Engrave mode is the best approach for the time being.

I can also confirm that we have a task on our backlog to address the placement of tremolo beams between whole notes/semibreves so that you don’t need to make manual adjustments in that case. It’s not something we’re actively working on at the moment, but it’s certainly something we intend to address at some point.

@Michel_Edward, I’m delighted to hear that overall you are finding Dorico to be a useful and powerful tool. I know it’s no small thing to consider using a new tool after decades using another one, and I’m really pleased that you’re seeing some of the advantages over those other tools that we have worked hard to provide to Dorico users.

8 Likes