Two parts and I want to change and not see blank meausures

I have a keyboard part that has multiple instruments and I want to see only one at a time…I have done this with percussion parts with great success, but not happening here… help?

Without seeing the project it’s pretty much impossible to know exactly what’s going wrong.

The most likely things are:

  1. Layout Options (for the relevant layout) > Players > Instrument Changes > Allow instrument changes - this needs to be ticked.
  2. There are times when multiple instruments contain music simultaneously.