UAD Instability - Loading in Playback

I’ve been experiencing great instability with UAD plugs. Watching the UAD meter it looks like there is zero activity when not playing back audio and upon hitting play, ALL the plugs load at once. So, it’s not surprising that on a large project this is causing crashes. I have 6 UAD cores (Duo + Quad - PCIe). I’m mastering a 16 songs CD. I’m trying to put one or two UAD plugs on each track (at the track level) Plus a couple at the Master level - I’m not even at 50% of my available UAD DSP but I’m getting crashes upon hitting play. It seems pretty clear that it’s the bottleneck of trying to load too much at once. I’ve looked in the preferences and can’t find a way to turn off this “unloading” in the background.

Anyone have any knowledge of this issue?

The plugins are always loaded. They are not re-loaded at startup. They are possibily “reset” if this option is active:
Better have it off in your case.

Thanks. I had checked that and it was off. If they stay loaded, then why does the UAD meter act the way it does? This doesn’t occur in Nuendo. The meter reflect the amount of DSP used at all times.

It’s pretty clearly a UAD issue too. It was specifically the Ampex plugin that I had on each track. I removed it from all tracks and placed it at the master level and everything worked fine. I’ve been slowly adding plugs here and there but keeping it below 30% capacity. This is a serious issue. Already I can’t use plugs such as the Ampex at the clip level because any cuts multiple DSP usage, now it seems I can’t reliably use it at the track level even when I have plenty of DSP available.

I’ll go over it all again today to make sure but it was a big problem on a mastering session yesterday. I know for a fact that in both states (checked and unchecked reset box) the UAD meter acts the same which is zero load upon stop.

When wavelab playback is stopped, nothing is sent to the plugins (no silence), hence there is no cpu used. This is normal and wanted.
This is not “normal” that too much uad plugins cause a crash. What uad says?

I haven’t contacted them, it just happened yesterday, but what you’re describing doesn’t match what I know of UAD. The UAD itself does not load or unload based on signal presence. In Nuendo whatever is loaded stays loaded all the time. THere’s an option in Nuendo to have VST3 plug only load with signal presence but again whether that option was checked or not never affected the UAD plugs. Probably b/c they weren’t VST3 last time I tried. I keep the dyn allocation off in Nuendo these days.

I’m going to open a ticket with UA now.

Ok, just got off the phone with UA. They stressed that the Ampex is a really DSP hungry plug but they agree that it sounds like WL is dynamically allocating the DSP on playback and that it might be causing a bottleneck. They’re suggestion was to load the plugs I would ideally use in a large WL session into Nuendo and see what the DSP allocation looks like there. If WL can handle the same amount as Nuendo (which does not dynamically allocated the UAD DSP) then…it’s just some kind of metering glitch with the UAD meter and really I’ve just run out of DSP.

I’m still working on client material today but I’ll run a test asap.

The UAD meter does have different behavior in Wavelab 8 than it did in Wavelab 7. In Wavelab 7 the meter would hold after stopping play. In Wavelab 8, it unloads. But I can’t get Wavelab 8 to crash because of this. I’ve taken UAD DSP to 80%, and over 100% without crashing. Over 100% it just displays the message “disabled one or more plugins”, like it normally does with too much UAD or Powercore. But I can’t get it to crash. I don’t have hungry plugins like Ampex or Manley to try though. Just alot of smaller ones. But the behavior is different between Wavelab 7 and Wavelab 8 (Wavelab 7 doesn’t unload the UAD when you hit stop). The montage checkboxes in both versions have no effect on the UAD meter.

Win 7, Win XP