UAD Render Bug (silence at end)

I have just one continuous WAV file in Wavelab and have added track markers throughout because it’s a live concert.

At first I thought it was my iTunes and playback software causing glitches but after analyzing the actual rendered files, I see that the WAV files were rendered incorrectly. It seems that for this song, 47 milliseconds of silence is at the end of the file when there should be no silence.

I’ll post a picture of the montage and what the same spot looks like on the rendered WAV files.

There are only plugins on the montage master, not on any clips. When I did this particular render I chose the option of rendering to WAV and mp3 at the same time.

Even with no plugins there is some extra space on the rendered files that should not be there.

Not sure what you are doing. In the “bad” picture, you show a montage, and in the “good” picture, a wave file. The wave file being the rendered montage, why do you say it’s bad?

Both pictures are from a montage.

The bad one is bad because there is 47ms of silence after the last audio but the two WAV files in the bad picture should line up seamlessly. The two WAVs were rendered from a continuous WAV shown in the good picture.

There is not enough information. I need to know the clip and CD marker placements. Please email me your empty montage (no audio file), the version without plugin.

I will e-mail the montage but this seems to come from a certain plugin after closer investigation.

The UAD Dangerous BAX EQ which happens to have 48ms of reported latency, the same amount of extra silence at the end of each rendered file from the montage. The extra silence is easy to see because this is a live continuous recording that should have NO silence at all.

Is there a problem with Wavelab compensating UAD latency?

Try this Jperkinski:

In the Render dialogue, select no tail.

No tail
If this option is activated, the audio tail produced by effects such as reverbs is not included in the rendered file.
Some plug-ins do not provide a tail duration to WaveLab. In this case, this option has no effect. For such plug-ins, you could add the Silence plug-in to add extra samples at the end of the file. An audio tail appears in this space.

Good luck.

Thanks, I did experiment with the no tail options and got the same results.

It seems I’m dealing with two separate problems.

#1 is that mp3 files seem to pad the beginnings and ends with silence, AAC and other formats are not as prone to this and also support the “gapless playback” option. The WAVs I render are just fine now that I’ve eliminated a few plugins (issue #2), but even when I make mp3s of these WAVs in other software, the files are no longer seamless.

PG, could Wavelab add a “part of gapless album” option to AAC and other formats that support that option? Sonnox Codec Toolbox Manager has a gapless box. I’m not sure if helps but it seems like a good idea.

#2 two seems to be that UAD BAX Dangerous EQ, and FabFilter Pro-Q2 are causing additional silence to the heads and tails of rendered WAV files. Removing these plugins for my particular montage solved the issue of WAV files having gaps when rendering an otherwise continuous file.

I will have to do more testing this evening to see if it’s all UAD or what is really causing the silence on the WAV files.

FabFilter Pro-Q2: when used in linear more, the latency is not correctly reported to the host. They are aware of the problem and will fix in a future version.

Concerning mp3, this format is quantized and not sample accurate.

Thanks or the info. I was unaware of the mp3 issue, do you think AAC is better? AAC at least sounds better in iTunes when going from one track to another with continuous audio.

More important, it seems there is a serious issue with rendering files with UAD BAX Dangerous EQ and a few other UAD plugins I tested.

I made a simple test tone and did some render tests. The files rendered with UAD are not late, but they do produce silence at the end. The amount of silence seems to be related to amount of plug in latency reported.

The images attached are a montage loaded with misc renders I just did. The source of the render is the top track. Anytime there is UAD BAX EQ or UAD Manley EQ inserted on the render ( see the title of the WAV in picture), there is 48 or 49ms (depends on BAX or Manley) of silence at the end of the file as you can see. The start image looks ok, the end image is where the problem is.

The renders on track 4 and 5 do not have the silence at the end because those renders did not contain a UAD plugin, just other plugins.

It seems that something when rendering with UAD causes silence in the amount of reported latency at the end of the file rather than rending the entire file. The starts of the files are OK so it’s not shifting anything, it’s just cutting off the last milliseconds of audio which is casing serious problems when rendering continuous audio into separate audio files based on CD track markers. Each rendered CD track has that 48ms of silence at the end.