UAD still not 64 Bit?!

[Rant on]

I can’t believe Universal Audio’s UAD platform isn’t 64bit yet. Clearly they’ve been putting most of the resources towards rolling out new plugs and fancy hardware like the Apollo. All good stuff, to be sure. But really - still no 64 bit on the UAD platform?!

I’ve been waiting for 2 things to happen before switching my computer over to a 64 bit os - one was getting an 8x8 midi unit that worked in a 64 bit environment and the other was having UAD plugs work at 64 bits. Well, Steinberg took care of the midi problem by updating drivers for the midex8.

UA needs to stop adding bells / whistles and get core functionality up to current specs. You aren’t going to have customers setting up XP computers, it’s Win7. Using a bridge is a pain. Isn’t this painfully obvious?
[Rant off]

Alrighty, I’m done complaining (for now). :smiley:

Hi, Tom,

I recently bought a UAD Solo card and a bunch of their plugins which all work very well in W7 x64 and Cubase x64 (VSTBridge). So far the only feature (that I know of) which does’nt work is the ability to use the mouse wheel to change settings.

They are in the process of changing to 64bit which will be free to existing customers, bloody great thing to know that :slight_smile:!



My UAD-2 quad-card works fine with Win7 x64 and Cubase x32.

They’re working on it. UAD-2 64-bit is coming.

I have been using UAD plugs in win Cubase 6 for over a year and they work great with VST bridge. I wouldn’t wait for the 64bit UAD upgrade as it will not effect the plugins functionality in cubase 6 64bit version. UAD does not work in “Vienna ensemble Pro 64” but do work in Vienna Ensemble Pro 32bit. I have heard that UAD will be upgrading soon though.

Wow. When I attempt to use UAD under Win 7 64 and Cubase 5 -64 and either Jbridge or the VStbridge, I can only do one instantiation of one plug-in

Odd I can run more than needed on any project, have you contacted them to address issue? Unsure why you would use jBridge with UAD plugs

Stories like Twilightsongs are what has held me back. That and I don’t want to fart around with bridges.

I used JBridge since the time the Cubase bridge wasn’t functioning correctly. I had been unaware that JBridge had been updated to correct this very issue, but even after updating it still didn’t work. So I deleted JBridge in order to use the Cubase bridge, which reportedly had been fixed. But it still didn’t work.

I am open to any suggestions here!

Send me a PM including your phone and email and we’ll set up a time to do a screen share. Your daw computer will of coarse have to be on internet…There isn’t enough info in your descriptions to diagnose problem :frowning: I will be happy to help if I can

  1. what version of UAD ru using

Alas - only for UAD-2 :cry:


I’m guessing that UAD-1, being a bit long in the tooth for quite some time, is simply not capable of running 64bit

I just got an email from them a few days ago, an open letter to UAD-1 users.
Apparently, the UAD 1 cards will still work as they always have, but in 32 bit and you won’t be able to update the software beyond v6.1.

Here’s the letter: