UAD2 Jbridge not showing in Cubase 8.5/9

I’m trying the advise of using bridged versions of UAD2 to get around the Windows dll limit that causes new plugins to not load in large sessions.

I’ve tried bridging both 32 and 64 bit versions of UAD2 but Cubase won’t recognize them. I see it scanning them but when it’s finished only about 3-4 show up in my plugin list (Raw, Inflator, and CS-1).

They work fine in Ableton and Wavelab so the bridging seems fine it’s just an issue with Cubase.

Anyone else seen this?


64 bit plugins are not compatible with Cubase 9. JBridge is possible , however you have to make sure that only the JBridged 64 bit versions are in a visible pathway. For instance the 32 bit plugins are installed into a separate folder and JBridged into a bridged folder that you can then add as a Cubase pathway. If Cubase sees the 32 bit dll it will be banned.

Hey thanks that worked. I needed to move the UAD plugs outside of the VSTPlugins folder and then point the Jbridge inside only. Now they show up.

Oh and Jbridge working great to extend how many plugins I can add.